Skip to:
Content

Opened 4 years ago

Last modified 20 months ago

#5814 reopened defect (bug)

Link to Blog Post in Activity/Feed is Broken

Reported by: allspark Owned by:
Milestone: Priority: normal
Severity: major Version: 2.0
Component: Activity Keywords: reporter-feedback
Cc: spark@…, sanket.parmar11@…

Description

We changed the permalinks on our site to "http://www.site.com/sample-post/". Now when we write a post and it gets published in the Activity stream (e.g., "John Smith wrote a new post,'New Post Title'" — the link to new post still uses the old permalink structure (i.e., http://www.site.com/?p=123/") resulting in a 404 error.

Also, when we change the title of the post, the new title does not get reflected in the Activity stream. It's still showing the old title.

Help please!

Change History (8)

#1 @DJPaul
4 years ago

Did you post this on the BuddyPress.org support forums? I feel like I've read this somewhere else, recently.

#2 @allspark
4 years ago

I may have, can't really recall. Or perhaps someone else may have the same issue.

#3 @r-a-y
4 years ago

  • Keywords reporter-feedback added
  • Priority changed from high to normal

the link to new post still uses the old permalink structure (i.e., http://www.site.com/?p=123/") resulting in a 404 error.

You shouldn't have a trailing slash in your post URL. example.com/?p=XXX is intentional and doesn't get updated because this should automatically redirect to the canonical post URL. Is this not the case for you? Do you have a link you can provide?

Also, when we change the title of the post, the new title does not get reflected in the Activity stream. It's still showing the old title.

This should be fixed in #5609. BP v2.1-beta should be getting released some time very soon, so if you're interested in testing, please wait until the beta drops.

#4 @DJPaul
4 years ago

@allspark we need some more details from you to debug this further; specifically Ray's question about the canonical permalinks.

#5 @DJPaul
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Closing due to lack of reporter feedback that we need to proceed. @allspark if you see this, please give us the extra information we've asked for, and we can take a look. Thanks!

#6 @unknownterritory20
3 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

Hi,

I have the same issue. To answer your question Ray, the trailing slash is not at the end. I think he may have placed it there accidentally. Upon clicking http://example.com/?p=20 it goes to a 404 and not the page it's referencing. Is there a quick patch that can be used to replace the page id with the page slug instead?

#7 @sanket.parmar
20 months ago

Hi @unknownterritory20,

I have tried to reproduce this issue with a fresh install and only BuddyPress v2.7.2 installed, but not able to do so.

I have tried by changing all the permalinks options but still it is redirecting to the correct post.

Do you have any specific steps for this issue?

#8 @sanket.parmar
20 months ago

  • Cc sanket.parmar11@… added
Note: See TracTickets for help on using tickets.