Skip to:
Content

BuddyPress.org

Opened 5 years ago

Closed 5 years ago

Last modified 3 years ago

#5777 closed enhancement (fixed)

Disambiguate the profile menus

Reported by: danbp Owned by: djpaul
Milestone: 2.1 Priority: normal
Severity: normal Version:
Component: I18N Keywords: has-patch
Cc: danco38@…

Description

I'm testing 2.1 Alpha and preparing the next release translation and found some areas for improvement.

Top right user menu and profile header nav and subnav
need a contextual string (_x) on all items for better translation.

0) Header menu
Activity | Profile | Notifications | Messages | Friends

1) Toolbar > User Menu
Profile (/membres/user/profile/)
      |--> View ( /membres/user/profile/public/)
	  |--> Edit ( /membres/user/profile/edit/)
	  |--> Avatar ( /membres/user/profile/change-avatar/)
	  
2) Notifications (/membres/user/notifications/)
      |--> Read (/membres/user/notifications/)
	  |--> Unread (/membres/user/notifications/read/)
	  
3) Settings (/membres/user/settings/)
	  |--> Account(/membres/user/settings/general/)
	  |--> Notifications /membres/user/settings/notifications/)
	  |--> Profile (/membres/user/settings/profile/)


On the settings page (3) there is a submenu with 3 items
Logically could be Account setting | Notifications setting | Profile setting.

When you translate Profile into Profile Setting for this sub menu, this will also modify Profile on the Header menu and on the User menu. Bad !

This is also true for Friends and Groups on the user menu and for the notification (read/unread) action button.

Aside, what is the logic behind the use of %s for 1 ?

For ex. Viewing topic %s to %s (of %d topic%s) = Viewing topic 1 to 1 (of 1 topic) is a bit ridiculous.
If you have only 1 topic, it is possible to write 1 topic (as used in single/groups/invites.php:14). Or this one is false or nearly 51 other plural strings could be modified.

"Viewing topic 1 (total)" seems enough to me (and probably for gettext also).

FYI, a good read here about Gettext usage (including plural arguments).

Attachments (3)

5777.patch (39.8 KB) - added by danbp 5 years ago.
5777.02.patch (2.9 KB) - added by imath 5 years ago.
5777.subnav.patch (559 bytes) - added by r-a-y 5 years ago.
Changes the "Profile > Profile" subnav tab back to "Profile > View"

Download all attachments as: .zip

Change History (18)

#1 @imath
5 years ago

  • Milestone changed from 2.0.2 to Awaiting Review

#2 @imath
5 years ago

Hi Dan,

changed the milestone to AR as you're talking about version 2.1 which will be released after 2.0.2 ;)

#3 @boonebgorges
5 years ago

  • Component changed from UX/UI to i18n
  • Keywords needs-patch added
  • Milestone changed from Awaiting Review to Future Release

Yes, let's add _x() to disambiguate the nav items. This will require a fairly systematic patch, so unless someone is willing to put in the necessary time very soon, it won't make it for 2.1.

Aside, what is the logic behind the use of %s for 1 ?

This comment is a duplicate of #5767

@danbp
5 years ago

#4 follow-up: @danbp
5 years ago

  • Keywords has-patch added; needs-patch removed

#5 in reply to: ↑ 4 @imath
5 years ago

Replying to danbp:

Hello danbp,

congratulations for this first patch !! :)

#6 follow-up: @DJPaul
5 years ago

  • Milestone changed from Future Release to 2.1

That's one amazing patch. :)

#7 @djpaul
5 years ago

In 8705:

i18n: disambiguate nav items' strings.

See #5777, props danbp

#8 in reply to: ↑ 6 @danbp
5 years ago

Replying to DJPaul:

That's one amazing patch. :)

Thank you ! I added another one here: #5767

@imath
5 years ago

#9 @imath
5 years ago

5777.02.patch is "fixing" some strings that needs to be echoed and that was simply returned since r8705

#10 @DJPaul
5 years ago

Good catch; I missed those going through it. My bad. :)

#11 @djpaul
5 years ago

  • Owner set to djpaul
  • Resolution set to fixed
  • Status changed from new to closed

In 8706:

i18n: correct some typos made in r8705

Some strings were being returned when they should have been echo'd to the screen.
Props imath, fixes #5777 again

#12 @r-a-y
5 years ago

One niggle - if you navigate to "Profile > View" from the WP Toolbar, the subnav item is now labelled "Profile".

So the nav structure looks like:

Profile
> Profile
> Edit
> Change Profile Photo

"Profile > Profile" seems redundant to me.

Any objections to switching the subnav tab from "Profile" back to "View" to match the WP Toolbar?

#13 @DJPaul
5 years ago

If you do be sure to add appropriate context to the string so that this can be clearly understood by translators

@r-a-y
5 years ago

Changes the "Profile > Profile" subnav tab back to "Profile > View"

#14 @r-a-y
5 years ago

In 8992:

XProfile: Rename "Profile > Profile" subnav tab back to "Profile > View".

See #5777.

#15 @DJPaul
3 years ago

  • Component changed from Locale - i18n to I18N
Note: See TracTickets for help on using tickets.