Skip to:
Content

BuddyPress.org

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#5726 closed defect (bug) (no action required)

When editing a topic I can select a forum from a private group I'm not part of

Reported by: gcmo Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.0
Component: Forums Keywords:
Cc:

Description

When editing a topic I can see an input to select a new forum to move the topic to

The issue is that in the list of forums to pick I can see forums belonging to private groups I’m not part of

If I select one of those and submit the post gets moved there correctly and I get redirected to the group->forum page where I correctly see a notice stating I can't see the message

I think I shouldn’t see those forums in the first place

--
BBPress 2.5.3
BuddyPress 2.0.1
Logged in with a contributor role

Change History (5)

#1 @boonebgorges
7 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Thanks for the report, gcmo. This functionality is provided by bbPress itself, so their Trac is the best place to report the issue: https://bbpress.trac.wordpress.org. Feel free to link back to this ticket when you do.

#2 @gcmo
7 years ago

Thanks Boone for the feedback

Actually I realised just now it might be a misalignment between bbPress and BuddyPress visibility system

Private forum in bbPress means: visibile only to logged in users
Private group in BuddyPress means: visible only to group members

Should I still post it over there anyway?

#3 @boonebgorges
7 years ago

Good point, gcmo. In this case, I think it's still a bbPress issue, because bbPress should be taking care of the proper translation of the 'privacy' issue, at least as far as the BuddyPress integration is concerned. Thanks.

#4 @gcmo
7 years ago

Ok I'll post over there! Cheers

#5 @netweb
7 years ago

bbPress Ticket #bbPress2639

Note: See TracTickets for help on using tickets.