Skip to:
Content

BuddyPress.org

Opened 7 years ago

Closed 7 years ago

#5611 closed defect (bug) (no action required)

Search does not work

Reported by: sooskriszta Owned by:
Milestone: Priority: highest
Severity: blocker Version:
Component: Core Keywords:
Cc: vivek@…, mpa4hu@…

Description

BuddyPress automatically links all text in user profile fields between commas, e.g. http://csillamvilag.com/modellek/modell/angelaveress/
(not a great idea)

However, when you click on the links, they lead to empty search results pages, e.g. http://csillamvilag.com/modellek/modell/?s=Felnőtt+modell

In other words, the search is buggy. It's not performing a text search within xprofile fields.

This is terrible user experience.

Expected action would be:
On clicking the auto-created links, a text search is performed on all single xprofile field values, and all multi xprofile option names.

The auto-linking should be disabled at least until the search is fixed.

Change History (6)

#1 @sooskriszta
7 years ago

  • Cc vivek@… added
  • Priority changed from high to highest
  • Severity changed from critical to blocker
  • Summary changed from Zero results on clicking auto-created links in xprofile fields to Search does not work

Actually, it seems that search is just terrible, irrespective of the auto-linking of xprofile text. e.g. http://csillamvilag.com/modellek/modell/?s=Veress

#2 @mpa4hu
7 years ago

  • Cc mpa4hu@… added

It works in every buddypress site I have seen, maybe that site is buggy (it is).

Also will argue about

not a great idea

Anyways you can change how fields are dispayied in template "profile-loop.php"

#3 @sooskriszta
7 years ago

The site is a fresh install, with latest versions of everything. Perhaps this is a regression? Please can you check (and post) the function in one of your sites running 2.0.1?

#4 follow-up: @mpa4hu
7 years ago

I just updated to 2.0.1, still works.
Try to switch to default theme, might be problem there or your bp-custom.php

/* Exclude vpundir from member lists */ function oc_filter_ajax_querystring( $querystring = '', $object = '' ) { if( $object != 'group_members' ) return $querystring; $querystring['exclude'] = '1'; // change '1' to your user_id return $querystring; } add_filter( 'bp_ajax_querystring', 'oc_filter_ajax_querystring', 20, 2 )

this looks weird can can be the problem (maybe somwhere you start your functions without opening <?php

And what function you mean?
If you mean to display just plain text you can try to remove this filters

add_filter( 'bp_get_the_profile_field_value',           'xprofile_filter_format_field_value', 1, 2 );
add_filter( 'bp_get_the_site_member_profile_data',      'xprofile_filter_format_field_value', 1, 2 );
add_filter( 'bp_get_the_profile_field_value',           'xprofile_filter_link_profile_data',  9, 2 );

If you confirm that this is a problem on your side (and not general) you can close this and contact me at mpa4hu@…, I'll try to help you with this problem.

Version 0, edited 7 years ago by mpa4hu (next)

#5 @boonebgorges
7 years ago

looks like your users are not activated (never logged in) and will not be dispayied in members. change sorting to alphabetical and it will work

Thanks, mpa4hu. sooskriszta, will you please verify that this is what's happening for you? If so, it's not a regression, and is expected behavior.

As for the auto-linking being "not a great idea", I agree that the behavior here could be improved in a number of ways. Please feel free to open an enhancement ticket with some ideas, if you'd like.

#6 in reply to: ↑ 4 @sooskriszta
7 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Replying to mpa4hu:

looks like your users are not activated (never logged in) and will not be dispayied in members. change sorting to alphabetical and it will work

That was it. Thank you!
Not sure why sorting would make a difference in terms of who is displayed, though. It's sorting, not filtering.

Note: See TracTickets for help on using tickets.