Skip to:
Content

BuddyPress.org

Opened 10 years ago

Closed 7 years ago

#5601 closed enhancement (maybelater)

Activity item: post link

Reported by: slaffik's profile slaFFik Owned by:
Milestone: Priority: low
Severity: minor Version:
Component: Activity Keywords: needs-patch
Cc:

Description

I have published a post on a site, and it appeared in activity stream, shortened, with a [Read more] link to a full version.

That link ignores the global Permalink settings from wp-admin area, as I have /%postname%.html there, while [Read more] link is /?p=12321

That's at list an inconsistent behaviour. And extra work for search crawlers.

Change History (2)

#1 @boonebgorges
10 years ago

  • Keywords needs-patch added
  • Milestone changed from Awaiting Review to Future Release
  • Priority changed from normal to low
  • Severity changed from normal to minor
  • Type changed from defect (bug) to enhancement

This is intended behavior. See r7447 #4367

We now dynamically generate activity action strings, so some of the force of the original ticket is lost. However, we *do* still cache the post URL in activitymeta, at least in the case of 'new_blog_comment'; see https://buddypress.trac.wordpress.org/browser/trunk/bp-blogs/bp-blogs-activity.php#L94. So we still have essentially the same problem: when a post link is changed (either by changing the specific permalink or by changing permalink settings and invalidating *all* cached URLs) the cached value has to be flushed. And in the case of 'new_blog_post', we would have to institute a similar activitymeta caching strategy, since we'd no longer be able to concatenate the URL reliably using the post id.

To "fix" the issue here, we would need to do proper invalidation of 'post_url' and 'post_title' activitymeta. This is a lot of work. There are many places where we'll have to check for invalidation. And in the case where *all* post_url values are made incorrect, we would have to have a fairly easy way of wiping them all out. (Like, say, deleting them all and then letting them regenerate individually when bp_blogs_format_activity_action_new_blog_comment() is run.)

I'm not fundamentally opposed to making these changes, but they are a lot of work to fix something that arguably is not really broken. I'll put this ticket into Future Release, and if anyone would like to take it up as a project, please feel free.

#2 @slaFFik
7 years ago

  • Milestone Future Release deleted
  • Resolution set to maybelater
  • Status changed from new to closed

As no one (including and especially me) showed the interest in this minor change that requires a ton of work - I'm closing the ticket.

Note: See TracTickets for help on using tickets.