Skip to:
Content

BuddyPress.org

Opened 6 years ago

Closed 3 years ago

Last modified 3 years ago

#5582 closed feature request (duplicate)

Default sort criteria filters for group lists

Reported by: sooskriszta Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Settings Keywords:
Cc: vivek@…

Description

BP allows multiple ways of sorting group lists:

  • Last active
  • Most members
  • Newly created
  • Alphabetical

We should offer admins the ability to decide the default sort order they want to implement on their sites (as opposed to force sorting on all sites by "last active").

The configuration could take the form of a wp-config filter.

Attachments (2)

patch_5582.zip (2.4 KB) - added by web24coder 4 years ago.
Patch #5582
2015-07-28_0840.png (64.9 KB) - added by web24coder 4 years ago.
2 dropdowns

Download all attachments as: .zip

Change History (15)

#1 @sooskriszta
6 years ago

  • Cc vivek@… added

#2 @sooskriszta
6 years ago

I meant wp-config constant or bp-custom.php filter.

Any chance this will get into 2.1?

#3 @DJPaul
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Closing as dupe of #5526

#4 @sooskriszta
6 years ago

  • Component changed from Core to Settings
  • Resolution duplicate deleted
  • Status changed from closed to reopened

Not a duplicate. #5526 is about lists of users (including member directories).

#5582 advocates similar function for lists of groups.

#5 @boonebgorges
6 years ago

  • Milestone set to Future Release

@web24coder
4 years ago

Patch #5582

#6 @web24coder
4 years ago

  • Milestone changed from Future Release to 2.3.3
  • Version set to 2.2.1

2 dropdowns were added. Now Admin can set default sorting and order of sorting.

Last edited 4 years ago by web24coder (previous) (diff)

@web24coder
4 years ago

2 dropdowns

#7 @DJPaul
4 years ago

  • Keywords has-patch needs-testing added
  • Milestone changed from 2.3.3 to 2.4

Thanks for yet another patch, @web24coder! We'll check it out soon.

#8 @DJPaul
4 years ago

  • Keywords dev-feedback added
  • Milestone changed from 2.4 to Under Consideration

Core team: do we want this feature?

#9 @DJPaul
4 years ago

  • Keywords 2nd-opinion added

#10 @DJPaul
3 years ago

  • Milestone changed from Under Consideration to Awaiting Review

#11 @DJPaul
3 years ago

  • Keywords needs-patch added; has-patch needs-testing dev-feedback 2nd-opinion removed
  • Milestone changed from Awaiting Review to Future Release
  • Type changed from enhancement to feature request

Let's do it, but we should do this for all components/lists at the same time.

#12 @slaFFik
3 years ago

  • Keywords needs-patch removed
  • Milestone Future Release deleted
  • Status changed from reopened to closed
  • Version 2.2.1 deleted

In #2147 decided to go first with an apply_filters route, so closing this ticket as duplicate of #2147.
Further development will be there.

#13 @slaFFik
3 years ago

  • Resolution set to duplicate
Note: See TracTickets for help on using tickets.