Skip to:
Content

BuddyPress.org

Opened 10 years ago

Closed 8 years ago

#5577 closed defect (bug) (no action required)

xProfile Field Groups rendered in wrong order in User > Profile > View Screen

Reported by: mercime's profile mercime Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Extended Profile Keywords: close
Cc:

Description

WP and BP trunk, new test WP install.

Extended Profile Field Groups created in Dashboard > Users > Profile Fields with at least 1 profile field per group show up in order in the Dashboard > Users > All Users > Extended Profile link screen and in Users > Profile > Edit screen but not in Users > Profile > View screen per attached screenshot.

Attachments (1)

field-groups-awry.png (34.1 KB) - added by mercime 10 years ago.

Download all attachments as: .zip

Change History (19)

#1 @mercime
10 years ago

Checked BP 1.9+ with WP 3.8+ install and the profile field groups were in order there.

Last edited 10 years ago by mercime (previous) (diff)

This ticket was mentioned in IRC in #buddypress-dev by Mercime. View the logs.


10 years ago

#3 @boonebgorges
10 years ago

Thanks for the details, mercime.

I can't reproduce this. I've tried on several different installations, running various combinations of WP and BP versions. I even tried enabling the APC cache and moving stuff around to see if that was the source of the problem, but to no avail. Groups are appearing in order everywhere I look.

Can you give more specific steps to reproduce? It's possible that I'm missing something critical. Or perhaps you can share a dump of the xprofile tables in your database?

#4 @mercime
10 years ago

Thank you looking into this issue Boone. Good to know that it could just be happening on test intallations I was using to create the BP screenshots for the readme.txt.

Dump of xprofile tables http://pastebin.com/X5ZcEtDU

#5 @boonebgorges
10 years ago

Thanks for the additional details, mercime. But even when using this exact data, I can't reproduce - groups are showing up as expected, even for the exact user displayed in your screenshot.

There is one bit of funny business I've noticed, which is that the group_order column in your xprofile groups field is 0 for each group. This happens when the groups are initially created, and have not been reordered manually (by dragging and dropping the tabs in Dashboard > Users > Profile Fields). That said, with group_order=0, the query should fall back on the primary key for ordering the fields, which is the "correct" order. That's what's happening on my test install.

It's not clear to me under what circumstances BP (or mysql) would choose to order them Charities, Hobbies, Base, Work Experience. It's not alphabetical, doesn't match the creation order, etc.

Anything coming to mind that I may have missed?

#6 @mercime
10 years ago

Looked into this issue further and I think that it could be closed as invalid.

  1. XAMPP install in USB stick on Windows 8 machine, WP/BP trunks - where I saw this issue first.
  2. XAMPP install in Windows 7, WP/BP trunks - same issue.

Following tests done recently:

  1. VVV on Windows 8, WP/BP trunks - no issue
  2. VVV on Windows 7, WP/BP trunks - no issue

All had User Switching and BP Default Data plugins activated. So at this point, could be that the XAMPP installs are corrupted in one way or another.

Thank you for taking the time to check the issue or non-issue as this turned out to be.

#7 @boonebgorges
10 years ago

Thanks very much for the additional environment details, mercime. They indicate (to me at least) that there could be a legit problem that only comes up in Windows environments. I'll have a closer look in a few days when I have access to my Windows box again.

#8 @DJPaul
10 years ago

Does anyone else have a Windows dev environment to try this in?

#9 @DJPaul
10 years ago

  • Milestone changed from Awaiting Review to Future Release

#10 @mercime
10 years ago

  • Milestone Future Release deleted
  • Resolution set to invalid
  • Status changed from new to closed

Thank you boonebgorges and DJPaul for your consideration of this issue. I recommend closing this ticket now as my new test sites in XAMPP for both Windows 7 and 8 machines do not have this issue at all. In addition, there were no reports of any such issue in the BP/WP forums during the period and up to present as well.

It could very well be a case where the SVN checkout of WP/BP trunk versions on both XAMPP installs were not compatible at that point in time. Just my luck :)

#11 @r-a-y
10 years ago

Does anyone else have a Windows dev environment to try this in?

Just tested. Appears to work fine on the "Profile > View" page.

However, I encountered an object cache issue when the XProfile groups are re-ordered. Will create a new ticket for this.

#12 follow-up: @quinngoldwin
9 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

I'm having this same problem. On the boss theme. I remember it being in the correct order at some point so it might be a plugin issue. I'm going to look further into this and start disabling plugins but I'm going to wait till later tonight when I have less traffic.

I use ubuntu 14.04
apc cache,
Boss theme 1.17 (choose show mobile on both desktop and mobile devices) "so its actually rendering the mobile css even on a desktop.

Plugin list

Buddy dev bp auto login on activation
buddy dev stealth mode for site admin
all in one wp security
better wordpress minify
BP default email notification settings control
BP redirect to profile
BP You are blocked
BUddy Dev Branded login for buddy press
BuddyBoss Wall
Buddypress Automatic Friends
Buddypress BLock Activity Steam types
Buddypress Captchia
Buddypres Edit Activity
Buddypress GLobal Search
Buddypress Username Changer
Email Login
Google Authenticator
Mailchimp for WOrdpress
Spam Referrer BLock
Stop Spammers Spam Control
WP better emails
wp Mandrill
Wp User Avatar

Last edited 9 years ago by quinngoldwin (previous) (diff)

#14 in reply to: ↑ 12 @quinngoldwin
9 years ago

UPDATE: I've deactivated all plugins, reinstalled buddypress, changed my theme to default wordpress 2015 and it still happens in mobile environment. It is not a theme or plugin issue, it looks like it has to do with the core of Buddypress. Is there a quick fix with CSS that we can implement in the meantime until there is an update on this. Thanks so much.

Specs
Wordpress 4.2.2
Buddypress 2.3.2
On 2015 theme and Boss Theme
Deactivated all plugins
I use APC cache and I reset the cache during test

Replying to quinngoldwin:

I'm having this same problem. On the boss theme. I remember it being in the correct order at some point so it might be a plugin issue. I'm going to look further into this and start disabling plugins but I'm going to wait till later tonight when I have less traffic.

I use ubuntu 14.04
apc cache,
Boss theme 1.17 (choose show mobile on both desktop and mobile devices) "so its actually rendering the mobile css even on a desktop.

Last edited 9 years ago by quinngoldwin (previous) (diff)

#15 @quinngoldwin
9 years ago

Problem Solved :

All I did was create a blank Field Group and Move my Resume field to another position and it fixed itself.

#16 @boonebgorges
9 years ago

quinngoldwin - Thanks for the details. The fact that you're using APC - and that creating a new field fixed the problem - strongly suggests to me that this is cache-related. If you're still able to reproduce the issue, could you test it with APC disabled?

#17 @mercime
8 years ago

Closing this as no one has reported any recurrence since last year.

#18 @mercime
8 years ago

  • Keywords close added
  • Resolution set to invalid
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.