Skip to:
Content

Opened 4 years ago

Closed 4 years ago

#5562 closed defect (bug) (fixed)

Disabling threaded comments in the admin does not affect activity stream comments

Reported by: pollyplummer Owned by: boonebgorges
Milestone: 2.1 Priority: normal
Severity: normal Version: 2.0
Component: Activity Keywords: needs-patch
Cc: slava.abakumov@…, keepingcozy@…

Description

This is a follow-up to #2768. I've found that BuddyPress respects WordPress' comment depth settings when set to any number. However, when threaded comments are disabled (the box is not checked), then the BP comment replies go back to unlimited. The expected behavior would be to have comment replies completely turned off if threaded comments are set to disabled.

Change History (8)

#1 @pollyplummer
4 years ago

  • Keywords needs-patch added; reporter-feedback removed

#2 @slaFFik
4 years ago

  • Cc slava.abakumov@… added

#3 follow-up: @boonebgorges
4 years ago

  • Milestone changed from Awaiting Review to 2.1

Good idea, though this needs a bit of thought before implementing. What's the default WP setting here? If it's disabled, that means that activity comments will be disabled by default. That seems like a poor user experience for new installations (even worse for upgrades).

#4 in reply to: ↑ 3 @pollyplummer
4 years ago

Replying to boonebgorges:

Good idea, though this needs a bit of thought before implementing. What's the default WP setting here? If it's disabled, that means that activity comments will be disabled by default. That seems like a poor user experience for new installations (even worse for upgrades).

It loos like they are enabled to 5 levels deep by default on new installs.

#5 @boonebgorges
4 years ago

Cool, that makes it easier. I guess the concern would be for existing sites that have manually disabled comment threading - they'd suddenly see activity comments disabled after upgrade. Is there something we can do in terms of UX - either at upgrade time, or somewhere in the UI - that might serve to indicate the reason why activity replies have been disabled?

I guess I'm particularly concerned about this change because it seems much less transparent than numerical comment depth. If I set my WP comment depth to 2 when I set up my blog, and the later install BP and see that comment depth is only 2 deep (or rather, became 2 deep after upgrading to 2.0), this is probably not a very jarring experience. However, if I disable threading altogether in WP (again, a long time ago, for unrelated reasons - like maybe my theme didn't handle it right), and then find later than an entire feature is entirely missing from BP, I'd be very confused.

Maybe I'm overthinking? Feedback welcome.

#6 @pollyplummer
4 years ago

  • Cc keepingcozy@… added

My initial report was a bit wrong in saying that "The expected behavior would be to have comment replies completely turned off if threaded comments are set to disabled." Actually, the expected behavior would be that threading is turned off. Commenting on activity items would still be open, but threading beneath would be turned off. So it wouldn't disable the activity commenting feature altogether, in the same way that disabling threaded comments in the discussion settings doesn't disable commenting. But I do agree that it might be jarring to have threading suddenly at 2 in the activity stream. Upgrading to 2.0+ doesn't retroactively disable all the threaded comment trees - it just changes the ability to reply within the tree. I think that the lack of threading would soon be discovered, if it's important. What about having a separate activity comment threading setting in the BuddyPress settings menu? Because it isn't at all clear that the Discussion settings for comments also work for BP activity.

#7 @boonebgorges
4 years ago

Actually, the expected behavior would be that threading is turned off. Commenting on activity items would still be open, but threading beneath would be turned off.

Yes. On further reflection, this seems right to me. (Though I will note that WP's own UI is a bit confusing on this point. In the dropdown for threading depth, they don't offer an option of 1. I take this to mean that selecting *2* offers *1* level of threading, for a total of 2 levels of comments.)

#8 @boonebgorges
4 years ago

  • Owner set to boonebgorges
  • Resolution set to fixed
  • Status changed from new to closed

In 8402:

Disable activity reply threading if WP comment threading is disabled

In r8201, BP adopted WP's thread_comments_depth setting for its own activity
reply threading. See #2768. However, the thread_comments toggle was not
respected. The current changeset adds support for thread_comments, so that
disabling WP comment threading will also enable nested activity comments
(though the top level of comments will still be allowed).

Fixes #5562

Note: See TracTickets for help on using tickets.