Skip to:
Content

#5537 closed defect (bug) (fixed)

WP Adminbar subnav item order not the same as profile nav order

Reported by: r-a-y Owned by: boonebgorges
Milestone: 2.0 Priority: normal
Severity: normal Version: 2.0
Component: Component - Core Keywords: has-patch commit
Cc:

Description

From a report on the forums:

  1. The user profile in wp admin bar in the activity tab first sub link is Mention and then second one is Personal…should be other way round…
  1. Settings tab/wp-admin bar menu has a new link called “Profile”..this comes as 1st link in wp admin bar…should be the 3rd link…

http://buddypress.org/support/topic/buddypress-2-0-rc1-feedback/

I've attached a patch.

First item is pretty straightforward. Second one requires hooking into the settings admin nav before the admin bar is rendered. The latter is what I have question marks on.

Let me know what you think.

Attachments (1)

5537.01.patch (3.0 KB) - added by r-a-y 13 months ago.

Download all attachments as: .zip

Change History (5)

@r-a-y13 months ago

comment:1 @DJPaul13 months ago

Do you know if this is a regression from 1.9.x?

comment:2 @r-a-y13 months ago

1st item is old. BP 1.5-old.
2nd item is being introduced in 2.0 because of the new "Settings > Profile" tab.

comment:3 @boonebgorges13 months ago

  • Keywords commit added
  • Milestone changed from Awaiting Review to 2.0

Second one requires hooking into the settings admin nav before the admin bar is rendered. The latter is what I have question marks on.

Wow, so dumb, such stupid, that we have to do this. As long as the WP admin bar is built in order of hooked operations, I don't see that we have a better option.

It's annoying to have to fix this after an RC, but I guess it won't cause any harm.

comment:4 @boonebgorges12 months ago

  • Owner set to boonebgorges
  • Resolution set to fixed
  • Status changed from new to closed

In 8277:

Proper ordering for Settings subnav items in WP Admin Bar

Fixes #5537

Props r-a-y

Note: See TracTickets for help on using tickets.