Skip to:
Content

BuddyPress.org

Opened 6 years ago

Closed 5 years ago

#5530 closed defect (bug) (fixed)

BuddyPress 2.0-beta2 Registration Page Fatal Error

Reported by: msaizan Owned by: imath
Milestone: 2.1 Priority: normal
Severity: normal Version: 1.6
Component: Core Keywords: has-patch commit
Cc:

Description

http://screencast.com/t/YKXTfd0sniRT

Fatal error on the registration page. This is a fresh multisite install - 2014 theme. no plugins.

Attachments (1)

5530.diff (4.8 KB) - added by imath 6 years ago.

Download all attachments as: .zip

Change History (11)

#1 @imath
6 years ago

  • Keywords reporter-feedback added

Hi msaizan,

Thanks for your feedback, I think this is due to the fact that the BuddyPress "blogs" (in other words "Site Tracking") component is not active.

Can you confirm the Blogs component is not active on your config ?

#2 @imath
6 years ago

  • Keywords has-patch added
  • Milestone changed from Awaiting Review to 2.0
  • Version set to 1.6

I think the problem is due to the function bp_blogs_subdomain_base() which was introduced in 1.6. As this function is in the Blogs component, if this component is not active, the function is not found because files are not loaded.

In 5530.diff, i suggest to "move" this function into the signup part of the members component to be sure it will be available.

@imath
6 years ago

#3 @imath
6 years ago

  • Keywords 2nd-opinion added

#4 follow-up: @msaizan
6 years ago

I enabled site tracking and the fatal error message is no longer displaying.

#5 @msaizan
6 years ago

  • Keywords reporter-feedback removed

#6 in reply to: ↑ 4 @imath
6 years ago

Replying to msaizan:

I enabled site tracking and the fatal error message is no longer displaying.

Thanks, it confirms my thoughts.

#7 @boonebgorges
6 years ago

  • Milestone changed from 2.0 to 2.1

Seeing as this is not a regression in 2.0, I'm wary of making this kind of change this close to release (even though you have deprecated properly). Let's do it for 2.1.

#8 @r-a-y
5 years ago

  • Keywords commit added; 2nd-opinion removed

Looks good, imath!

This ticket was mentioned in IRC in #buddypress-dev by paulgibbs. View the logs.


5 years ago

#10 @imath
5 years ago

  • Owner set to imath
  • Resolution set to fixed
  • Status changed from new to closed

In 8683:

Make sure to get the subdomain base on Multisite configs

Move the function to get the subdomain base out of the blogs component to be sure it will be retrieved (when registering a new blog) even if the blogs component is not active.

fixes #5530

Note: See TracTickets for help on using tickets.