Skip to:
Content

BuddyPress.org

Opened 8 years ago

Closed 8 years ago

#5488 closed defect (bug) (fixed)

some bugs on BP 2.0 beta

Reported by: danbp Owned by: boonebgorges
Milestone: 2.0 Priority: normal
Severity: normal Version:
Component: Toolbar & Notifications Keywords: has-patch
Cc:

Description

BP 2.0 beta testing with WP 3.8.1 and 2012 theme - local install with php 5.4.12 - mySql 5.6.12 - apache 2.2.4

1) When a user modify his avatar, that activity update mention stays empty on SWA & user activity. Thee line is blank and only the new avatar and the buttons are appearing.

2) User message notification on /user/notifications/ page

  • On the toolbar, the notification count is appearing but not the alert (<li> "You have x new notice (or similar)" is empty).
  • On the message screen, i have a php error. Warning: sprintf(): Too few arguments in C:\wamp\www\buddy\wp-content\plugins\buddypress\bp-messages\bp-messages-notifications.php on line 130
  • The string Viewing %1$s to %2$s (of %3$s notification) doesn't translate. (works with 1.9.2)

3) bp-groups-admin.php:477
Fonctionnality here is to add/remove members from a group. This phrase is not correct:
The following members were successfully modified: <em>%s</em>
Logically this should be:
The following members were successfully removed from this group: <em>%s</em>
Aside, this string needs a plural form. You can remove one OR more members from a group.

4) [typo}E-mail vs. Email in /admin/bp-members-classes.php:129,144,442,447
Same string with %s and %1$s usage ?
bp-xprofile_activity.php:102
%s&#8217;s profile was updated
testcases/xprofile/activity.php:356
%1$s&#8217;s profile was updated

Attachments (1)

5488.avatar_activity.patch (593 bytes) - added by r-a-y 8 years ago.

Download all attachments as: .zip

Change History (6)

#1 @boonebgorges
8 years ago

Thanks very much for the report, danbp. Can I ask you to please open separate tickets for each of them? They are all very different, and in particular some are not regressions from 1.9.

#2 @r-a-y
8 years ago

  • Keywords has-patch added

1) Attached patch - avatar_activity.patch - fixes this. We're referencing the wrong component name. See r4273.

2) Looks like our potbot hasn't been working recently, therefore our language file is out-of-date.

Here's a temporary .pot file generated by me:
http://pastebin.com/hHTqVy2G

3) and 4)
- We'll address this in some manner.

#3 @boonebgorges
8 years ago

Thanks, r-a-y. The avatar 'profile' thing is something I sorta threw my hands up about when doing the activity action stuff. Your fix looks fine.

I'll ping nacin about the potbot.

#4 @danbp
8 years ago

Just opened 3 separate tickets for the above report for point 2), 3) & 4)

#5 @boonebgorges
8 years ago

  • Owner set to boonebgorges
  • Resolution set to fixed
  • Status changed from new to closed

In 8208:

'new_avatar' profile type should have the component name 'profile'

This is for backward compatibility.

Fixes #5488

Props r-a-y

Note: See TracTickets for help on using tickets.