Skip to:
Content

BuddyPress.org

Opened 6 years ago

Closed 6 years ago

#5471 closed defect (bug) (duplicate)

Useless Big query

Reported by: elpix Owned by:
Milestone: Priority: high
Severity: major Version: 1.9.2
Component: Toolbar & Notifications Keywords:
Cc:

Description

Hi there !

When I'm not logged in on my website, I look at the sql queries on the page and I see :

SELECT * 
FROM wp_bp_notifications
WHERE component_name
IN (
'friends',  'messages',  'activity',  'groups',  'blogs',  'events'
)
AND is_new =1

I Think this query is useless, because this kind of query must be use to display notifications when the user is logged, but here I'm not logged !

How to remove that ? It's a very big query and it take 0,3 seconds to load on my website ...

Change History (3)

#1 @imath
6 years ago

  • Keywords reporter-feedback added

Hi elpix,

Thanks for your feedback, i think r-a-y already took care of it: see changeset r7966

In order to be sure, can you test using the trunk version of BuddyPress, to do so you can follow the instructions on http://buddypress.org/download/ section "Development"

#2 @elpix
6 years ago

Hi Mat,

I don't have any test environment unfortunately.
r-a-y seems to have done the correction, so I will wait for the next version of BP.

#3 @imath
6 years ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Ok closing as i really think it's a duplicate of #5413

r-a-y already took care of it.

Thanks again for your feedback elpix

Note: See TracTickets for help on using tickets.