Skip to:
Content

BuddyPress.org

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#5460 closed defect (bug) (fixed)

username with space

Reported by: akelm's profile akelm Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Core Keywords:
Cc:

Description

Hello
It is a bug in buddypress username with space, it not work properly with wordpress,
Example: if you register with username username, then buddypress add username-username in the buddypress profile, but for the WordPress link it using www.domain.com/usernameusername.
This can give some problems if you redirecting to the profile field.

Change History (5)

#1 @r-a-y
10 years ago

  • Keywords reporter-feedback added

I just tested and this is expected behavior.

If you register a username like "space space", you can login with "space space", but the at-mention name and url will be @space-space and example.com/members/space-space/ respectively. This is because at-mentions do not work with spaces and your profile URL should be sanitized for URLs.

Tested with root profiles enabled and disabled.

Profile URLs are also resolving properly for me.

What I'm wondering is why your profile link has the hyphen stripped from the URL. Do you have any other details about your set up?

#2 @akelm
10 years ago

when clicking on the budypress profile then we se it works fine, and profile page shows /username-username/fine, but the WordPress profile showin usernameusername not username-username as buddypress dos.

Otherwise, all other username withaout space working fine.
I using s2membership plugin, and redirect users to the profile page

[http://www.excampel.com/members/%%current_user_login%%/profile/]

Now it so the user profile how causing this case has the same user name and name
He signs up with the name: example example, and username example example,
No deference’s be twin username an name,
It can be the WordPress creating the link /usernameusername/, or mybe /namename/
It is difficult to I identify the link since the username and the name is the same name.

Last edited 10 years ago by akelm (previous) (diff)

#3 @r-a-y
10 years ago

Your problem is the usage of s2membership's user tags.

BP uses the user_nicename database field from the wp_users table by default.

It appears you are using s2membership's custom user_login tag, which looks like it strips spaces. See if s2membership offers a similar tag for user_nicename.

#4 @akelm
10 years ago

  • Resolution set to fixed
  • Status changed from new to closed

removed the link and everything seems normal, thanks for you help, only s2 membership error.

Last edited 10 years ago by akelm (previous) (diff)

#5 @r-a-y
10 years ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted

Cool, thanks for confirming!

Note: See TracTickets for help on using tickets.