Skip to:
Content

BuddyPress.org

Opened 10 years ago

Closed 10 years ago

Last modified 8 years ago

#5459 closed defect (bug) (duplicate)

wp 3.9 beta 1 wpdb::prepare missing placeholder warning

Reported by: offereins's profile Offereins Owned by:
Milestone: Priority: normal
Severity: normal Version: 1.9.2
Component: Core Keywords:
Cc:

Description

Testing with WP 3.9 beta 1: Calling bp_has_groups(), custom or on the groups admin page, returns a debug warning (Dutch):

Notice: wpdb::prepare had de verkeerde naam. The query argument of wpdb::prepare() must have a placeholder. Bezoek de Debugging in WordPress voor meer informatie.(Dit bericht is toegevoegd in versie 3.9.) in [site]/wp-includes/functions.php on line 3043

This is because of WP changeset 27073 originating from WP #25604. I wasn't able to immediately find the source of the issue. I'm also currently not aware of any other places this message shows up.

Change History (9)

#1 @Offereins
10 years ago

  • Component changed from Groups to Warnings/Notices

#2 @boonebgorges
10 years ago

  • Keywords reporter-feedback added

Thanks for the report. Can you please give more info about how to reproduce the error? I've tried initializing a custom bp_has_groups() loop in a number of places, but have been unsuccessful.

#3 @Offereins
10 years ago

  • Keywords reporter-feedback removed

As far as I can tell it even just happens on the groups admin page. No plugins but BP activated. I've currently 5 groups active, all created since BP 1.9.2.

#4 @boonebgorges
10 years ago

Thanks, Offereins. "Groups admin page" is ambiguous between a couple different things. Can you be specific? Dashboard > Groups? Dashboard > Groups > [specific group]?

#5 @Offereins
10 years ago

Hehe sorry for that. Just Dashboard > Groups. The Groups listing, the Groups overview, the Groups list table. But I'm guessing, since you're not sure what I mean, you haven't encountered the issue yet: it's also on my Edit Group admin page, I see now. Makes me wonder what's wrong with my installation.

Last edited 10 years ago by Offereins (previous) (diff)

#6 @boonebgorges
10 years ago

I'm guessing, since you're not sure what I mean, you haven't encountered the issue yet

Correct :)

Is there a way for you to get a more complete stack trace? If you can easily enable XDebug, that'll give it to you. Otherwise, go to the part of wp-db.php where the _doing_it_wrong() notice is thrown, and print_r( debug_backtrace() );. This'd help us track it down.

#7 @Offereins
10 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Ah I see, it's a duplicate of #5388. Did not see that ticket, sorry. You can continue your great work elsewhere ;)

#8 @boonebgorges
10 years ago

D'oh. I guess I should've checked more thoroughly with 1.9.x versions of BP. Thanks again for the report!

#9 @DJPaul
8 years ago

  • Component changed from Tools - Warnings/Notices to Core
Note: See TracTickets for help on using tickets.