Skip to:
Content

BuddyPress.org

Opened 10 years ago

Closed 10 years ago

#5444 closed enhancement (wontfix)

Add a new argument for BP_Menu_Walker sub-menu item that allows you to filter the UL class.

Reported by: bowromir's profile Bowromir Owned by: djpaul's profile DJPaul
Milestone: Priority: normal
Severity: normal Version:
Component: Core Keywords:
Cc: mercijavier@…

Description

Because the BuddyPress Navigation menus often are nested several layers deep, it would be nice if you could easily change the default nested <UL> elements generated by the bp_nav_menu function.

For example it could be something like:

<?php
    bp_nav_menu( array(
        'container'         => false,
        'menu_class'        => 'dropdown-menu',
        'sub_menu_class'        => 'sub-menu'
        )
    );
?>

This would make it easier to quickly change the BuddyPress navigation menus to various themes and frameworks (foundation/bootstrap etc).

Change History (6)

#1 @DJPaul
10 years ago

  • Milestone changed from Awaiting Review to 2.0
  • Owner set to DJPaul
  • Status changed from new to accepted

I think we should do this; it's a pretty quick change.

#2 @DJPaul
10 years ago

  • Keywords 2nd-opinion added

While we could add this to BP's walker without much effort, I'm thinking this suggestion is perhaps better suited for the WordPress core trac.

#3 @boonebgorges
10 years ago

If it's easy for us to do it, let's do it, and also submit an upstream patch. Just make sure our fix is easy enough to swap out if WP does implement the fix.

#4 @boonebgorges
10 years ago

  • Milestone changed from 2.0 to 2.1

#5 @mercime
10 years ago

  • Cc mercijavier@… added

#6 @DJPaul
10 years ago

  • Keywords 2nd-opinion removed
  • Milestone 2.1 deleted
  • Resolution set to wontfix
  • Status changed from accepted to closed

I've given this some thought, and agree with my earlier second opinion. We shouldn't touch this because it's not obvious what core might decide to call the parameter used to control a setting, and on balance, we'd probably call it something different and then have to end up maintaining backwards compatibility for ever. Closing as wontfix, and I'll search/make a ticket on core track as appropriate.

Note: See TracTickets for help on using tickets.