Skip to:
Content

BuddyPress.org

Opened 6 years ago

Closed 6 years ago

#5442 closed defect (bug) (no action required)

when user edit within profile is off log-in/out specific menu items break

Reported by: gingerling Owned by:
Milestone: Priority: normal
Severity: minor Version: 1.9.2
Component: Core Keywords:
Cc:

Description

In menu (in my case a sidebar menu) has items that are chosen from the buddypress box in appearance > menus. Log In and Join are only visible to users who are logged out. This works well except I found this bug:

When you uncheck settings > budypress > Components "Allow your users to modify their account and notification settings directly from within their profiles" and view the menu when you are logged in, shows the following mad lookin code in place of login and join. The rest of the menu below is fine.

Warning: strpos(): Empty delimiter in /var/lib/wordpress/wp-content/plugins/buddypress/bp-core/bp-core-filters.php on line 489 Call Stack: 0.0001 341020 1. {main}() /usr/share/wordpress/index.php:0 0.0002 344268 2. require('/usr/share/wordpress/wp-blog-header.php') /usr/share/wordpress/index.php:17 1.8181 4435556 3. require_once('/usr/share/wordpress/wp-includes/template-loader.php') /usr/share/wordpress/wp-blog-header.php:16 2.0572 4638868 4. include('/home/phplist/site/trunk/blog/wp-content/themes/phplist-community/page.php') /usr/share/wordpress/wp-includes/template-loader.php:47 3.3722 4797124 5. get_sidebar() /home/phplist/site/trunk/blog/wp-content/themes/phplist-community/page.php:44 3.3722 4797812 6. locate_template() /usr/share/wordpress/wp-includes/general-template.php:95 3.3723 4798008 7. load_template() /usr/share/wordpress/wp-includes/template.php:383 3.3725 4810544 8. require_once('/home/phplist/site/trunk/blog/wp-content/themes/twentyfourteen/sidebar-content.php') /usr/share/wordpress/wp-includes/template.php:407 3.3728 4810624 9. dynamic_sidebar() /home/phplist/site/trunk/blog/wp-content/themes/twentyfourteen/sidebar-content.php:15 3.3743 4813352 10. call_user_func_array() /usr/share/wordpress/wp-includes/widgets.php:904 3.3743 4813668 11. WP_Widget->display_callback() /usr/share/wordpress/wp-includes/widgets.php:0 3.3746 4814324 12. WP_Nav_Menu_Widget->widget() /usr/share/wordpress/wp-includes/widgets.php:182 3.3757 4817732 13. wp_nav_menu() /usr/share/wordpress/wp-includes/default-widgets.php:1120 3.3758 4821848 14. wp_get_nav_menu_items() /usr/share/wordpress/wp-includes/nav-menu-template.php:178 3.4997 4910716 15. array_map() /usr/share/wordpress/wp-includes/nav-menu.php:537 3.6181 4941376 16. wp_setup_nav_menu_item() /usr/share/wordpress/wp-includes/nav-menu.php:0 3.6192 4944920 17. apply_filters() /usr/share/wordpress/wp-includes/nav-menu.php:678 3.6193 4945872 18. call_user_func_array() /usr/share/wordpress/wp-includes/plugin.php:173 3.6193 4945900 19. bp_setup_nav_menu_item() /usr/share/wordpress/wp-includes/plugin.php:0 3.6194 4946392 20. strpos() /var/lib/wordpress/wp-content/plugins/buddypress/bp-core/bp-core-filters.php:489 

Attachments (1)

Screenshot from 2014-03-02 18:12:54.png (268.7 KB) - added by gingerling 6 years ago.
the code in my menu

Download all attachments as: .zip

Change History (5)

@gingerling
6 years ago

the code in my menu

#1 @boonebgorges
6 years ago

  • Milestone changed from Awaiting Review to 2.0
  • Severity changed from normal to minor

Thanks for the report. Needs more investigation, but it does appear to be a legit issue. (Devs, see bp_setup_nav_menu_item; there may be cases in which $menu_item->url is not getting set.)

For the time being, it's probably wise to disable error reporting on your public site. error_reporting( 0 ) in your wp-config.php file should do it.

#2 @boonebgorges
6 years ago

I can't seem to reproduce this. I've tried all sorts of combinations of toggling the Settings components alongside logged-in/logged-out users. Anyone else having luck? gingerling, can you provide any more details about the steps that lead to the error?

#3 @gingerling
6 years ago

This problem no longer seems to be happening (I tested extensively at the time however).

I don't know what we changed that fixed it exactly.

We had a lot of issues with bp initially because we used the Debian install script (http://paste.debian.net/87646/) to set up WP. Perhaps some change related to the fix for that. Here is the ticket https://buddypress.trac.wordpress.org/ticket/5433#ticket - it got resolved so maybe that will have some answers.

#4 @boonebgorges
6 years ago

  • Milestone 2.0 deleted
  • Resolution set to invalid
  • Status changed from new to closed

Very odd. Thanks for reporting back, gingerling. As it appears that this is not a problem with BP itself, I'm going to close the ticket. But if you do see it again, and can narrow it down to something that could be fixed in BuddyPress, please feel free to reopen with details.

Note: See TracTickets for help on using tickets.