Skip to:
Content

Opened 15 months ago

Closed 15 months ago

Last modified 13 months ago

#5438 closed defect (bug) (duplicate)

Buddypress bulk message deletion not working.

Reported by: Nishant_Official Owned by:
Milestone: Priority: high
Severity: major Version: 1.9.1
Component: Appearance - Template Pack Keywords: needs-patch
Cc:

Description

Hello Community,

I am developing an applicaiton using Buddypress 1.9.1 and WordPress 3.8.1. I am customizing BuddyPress with its template functionality. When testing message section, I was unable to bulk delete messages. The problem is already mentioned in thread - http://buddypress.org/support/topic/delete-selected-not-working/.

I found the problem with file:
\wp-content\plugins\buddypress\bp-templates\bp-legacy\js\buddypress.js @ line 1242

Problem was wrong calling of inArray() function.

I changed the code from

if ( -1 == jq.inArray( this.id ), Array( 'delete_sentbox_messages', 'delete_inbox_messages' ) )

to

if ( -1 == jq.inArray( this.id, Array( 'delete_sentbox_messages', 'delete_inbox_messages' )))

Everything is working fine now.

I hope I caught the right thing. If it was not please notify.

Thanks for writting this code poem named BuddyPress.

Nishant Kumar

Change History (12)

comment:1 @boonebgorges15 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Nishant_Official - Thanks so much for fix and especially for the nice comments :)

Turns out this is already fixed in trunk. #5347 r7740

Thanks again!

comment:2 @godavid3313 months ago

This is claimed as fixed, though I am using the most updated version of buddypress and still having the same problem. Do I have to pull from the trunk to get the truly most updated version or do y'all push it to the wordpress plugin repo?

comment:3 @boonebgorges13 months ago

It will be fixed in the 2.0 release, which is due later this week.

comment:4 @godavid3313 months ago

OOoooooooo can't wait :)

hope all goes well!

comment:5 @godavid3313 months ago

Is there an overview of the expected changes by any chance? I'm afraid this will be a major overhaul that will break all of my buddypress sites haha. But also I'd like to know what to expect, I'm sure there will be some features in this update that I might be about to custom code, so I'd rather just save myself the time if I'll end up just deleting my own code later

comment:6 @boonebgorges13 months ago

godavid33 - Check out the last few posts on http://buddypress.org/blog/ for some overview. In the next day or two, an official changelog will also be posted at http://codex.buddypress.org/releases/version-2-0

comment:7 @godavid3313 months ago

Awesome, thanks Boone!

comment:8 @Kilbey6213 months ago

2.0 and still not fixed

comment:9 @boonebgorges13 months ago

Kilbey62 - Please provide details on your theme. This was indeed fixed in bp-default. If you're using bp-default or a derivative, it was not fixed by 2.0.

comment:10 @Kilbey6213 months ago

I'm using Suffusion with Buddypress pack plugin installed on Wordpress 3.9. Thanks

comment:11 @r-a-y13 months ago

Suffusion with their template pack plugin is a bp-default derivative.

If you want to try theme compatibility that is built-in with BuddyPress as of BP 1.7, deactivate the Suffusion template pack plugin and follow these steps:
http://codex.buddypress.org/themes/theme-compatibility-1-7/bp-17-upgrading-template-packed-themes/

Backup your theme before doing this.

comment:12 @Kilbey6213 months ago

Perfect. This works and the site even looks much better that way. Thanks for the help.

Note: See TracTickets for help on using tickets.