Skip to:
Content

BuddyPress.org

Opened 10 years ago

Closed 10 years ago

#5412 closed defect (bug) (wontfix)

Ex-spammers absent from members directory

Reported by: henrywright's profile henry.wright Owned by:
Milestone: Priority: normal
Severity: normal Version: 1.9.1
Component: Settings Keywords:
Cc:

Description

If I go to /members/username/settings/capabilities and mark a user as a spammer, they are then excluded from the members directory. If I then choose to un-mark the same user as a spammer, that user continues to be excluded from the members directory.

Change History (2)

#1 @imath
10 years ago

  • Keywords reporter-feedback added

Hi henry.wright

That's because when a user is marked as a spammer BuddyPress user's data are deleted. When you unmark the spammer, the xprofile base Name field is recreated, but the last activity will be back as soon as the user will next login into the website.

Is it ok for you or what would be your suggestion about it ?

#2 @DJPaul
10 years ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

This is intended behaviour as this stands and I think we'd need a really good argument to change the behaviour of this. As imath said, the listing in the directory is dependant on the user's last_activity meta being set, which is done automatically once/if the user logs back in, which isn't an onerous requirement.

Note: See TracTickets for help on using tickets.