Skip to:
Content

BuddyPress.org

Opened 8 years ago

Closed 4 years ago

#5408 closed enhancement (maybelater)

bp_is_{component}_directory new helper functions

Reported by: imath Owned by: imath
Milestone: Priority: normal
Severity: normal Version:
Component: Core Keywords: needs-patch, dev-feedback, trac-tidy-2018
Cc:

Description

The patch is adding bp_is_{component}_directory() functions for each component that has a directory page. This ticket is a reply to the 2nd point of DJPaul in his comment to #5328

Attachments (1)

5408.diff (4.4 KB) - added by imath 8 years ago.

Download all attachments as: .zip

Change History (9)

@imath
8 years ago

#1 @boonebgorges
8 years ago

  • Keywords commit added

It seems weird to me that we would check is_multisite() when determining whether we're looking at the blogs directory. But that's probably a subject for another ticket, because what you've done here reproduces the current logic.

#2 @imath
8 years ago

  • Owner set to imath
  • Resolution set to fixed
  • Status changed from new to closed

In 7926:

Adds bp_is_{component}_directory new helper functions

To check if the current page is the activity, members, groups or blogs directory page, you can now use these new helper functions.

Props r-a-y, DJPaul

Fixes #5408

#3 @johnjamesjacoby
8 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

This is fine for now, but I have a hunch we'll end up changing some of this. The _is_ function names are fine, but they overlap with rewrite rules and determining directory pages.

It's also weird to me that none of these (currently or needed to) call bp_is_directory().

Can we confirm whether not other places in BuddyPress would benefit from using these new functions before we reclose this ticket?

#4 @boonebgorges
7 years ago

  • Keywords has-patch commit removed
  • Milestone changed from 2.0 to 2.1

#5 @DJPaul
7 years ago

  • Keywords needs-patch dev-feedback added
  • Milestone changed from 2.1 to 2.2

#6 @DJPaul
7 years ago

  • Milestone changed from 2.2 to Future Release

#7 @DJPaul
4 years ago

  • Keywords trac-tidy-2018 added

We're closing this ticket because it has not received any contribution or comments for at least two years. We have decided that it is better to close tickets that are good ideas, which have not gotten (or are unlikely to get) contributions, rather than keep things open indefinitely. This will help us share a more realistic roadmap for BuddyPress with you.

Everyone very much appreciates the time and effort that you spent sharing your idea with us. On behalf of the entire BuddyPress team, thank you.

If you feel strongly that this enhancement should still be added to BuddyPress, and you are able to contribute effort towards it, we encourage you to re-open the ticket, or start a discussion about it in our Slack channel. Please consider that time has proven that good ideas without contributions do not get built.

For more information, see https://bpdevel.wordpress.com/2018/01/21/our-awaiting-contributions-milestone-contains/
or find us on Slack, in the #buddypress channel: https://make.wordpress.org/chat/

#8 @DJPaul
4 years ago

  • Milestone Awaiting Contributions deleted
  • Resolution set to maybelater
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.