Skip to:
Content

BuddyPress.org

Opened 10 years ago

Closed 10 years ago

#5282 closed defect (bug) (fixed)

BP Groups screen notifications are not displayed (1.9-beta2)

Reported by: imath's profile imath Owned by: r-a-y's profile r-a-y
Milestone: 1.9 Priority: normal
Severity: major Version:
Component: Groups Keywords: has-patch
Cc:

Description

Hi,

Using 1.9-beta2 with the new notification component on. None of the group notifications are displayed to the user. bp_notifications_add_notification() function is writing new lines into the $wpdb->bp_notifications table but except for is_new field and date_notified one, values are empty.

The trouble seems to be that bp_notifications_add_notification() is waiting for an array of values and the groups_notification_[suffix] functions are sending a comma separated list of values.

So i built a patch and while building it i've noticed, the screen notifications were not marked to read if clicking on their link from the WP Admin Bar "bubble". I think the patch also fixes this issue, but i think it needs to be checked again.

I've put this bug as major for once, because i think it's a kind of "regression" regarding 1.8.1.

Attachments (1)

5282.diff (4.5 KB) - added by imath 10 years ago.

Download all attachments as: .zip

Change History (4)

@imath
10 years ago

#1 @r-a-y
10 years ago

  • Keywords needs-testing removed
  • Milestone changed from Awaiting Review to 1.9
  • Version 1.8.1 deleted

Confirmed! Thanks so much for testing and for patching, imath.

#2 @r-a-y
10 years ago

In 7652:

Groups: Fix invalid arguments for new notification function calls.

See #5266, #5282.

Props imath.

#3 @r-a-y
10 years ago

  • Owner set to r-a-y
  • Resolution set to fixed
  • Status changed from new to closed

In 7653:

Groups: Fix notifications not being cleared on certain screens.

The 'do_action' hooks were referencing the wrong actions for the
group home and group invites pages. Thus, notifications were not
being cleared on those pages.

Fixes #5282.

Props imath.

Note: See TracTickets for help on using tickets.