Skip to:
Content

BuddyPress.org

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#5270 closed defect (bug) (wontfix)

Ugly URLs in activity stream 'new post' entries

Reported by: henrywright's profile henrywright Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Blogs Keywords:
Cc:

Description

An activity entry for a new post looks something like:

Member X wrote a new post, Post Title 2 minutes ago

The phrase 'Post Title' is hyperlinked and takes the user to the single post page. If you inspect the 'Post Title' URL, you will see it is ugly example.com/?p=30 and doesn't honour the WP admin permalink settings.

Notes on the environment this was tested on:

  1. Site Tracking enabled
  2. Permalink settings set to /%post_id%/
  3. BP 1.9 beta 1
  4. WP 3.7.1
  5. Twenty Twelve

Change History (3)

#1 @henrywright
10 years ago

In bp-blogs-functions.php at line 323 i'm thinking replace

$post_permalink = add_query_arg(
    'p',
    $post_id,
    trailingslashit( get_home_url( $blog_id ) )
);

with

$post_permalink = get_permalink( $post_id );

This works for standard BP but I haven't been able to test on multisite.

#2 @r-a-y
10 years ago

  • Component changed from Core to Blogs
  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

This is by design.

See #4367 as to why.

You can override this with the 'bp_blogs_activity_new_post_primary_link' filter if you do not like the change.

#3 @henrywright
10 years ago

Thanks r-a-y

Note: See TracTickets for help on using tickets.