Skip to:
Content

BuddyPress.org

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#5243 closed defect (bug) (no action required)

Private messages search doesn't return message threads authored by deleted users

Reported by: henrywright's profile henrywright Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Core Keywords:
Cc:

Description

The private messages search doesn't return message threads that were written by users who have been deleted, yet these (orphaned?) message threads remain in an active user's inbox and sentbox.

Attachments (1)

search-deleted-message.png (28.5 KB) - added by imath 10 years ago.

Download all attachments as: .zip

Change History (10)

#1 @henrywright
10 years ago

  • Summary changed from Private messages search doesn't return message threads authored by delete users to Private messages search doesn't return message threads authored by deleted users

#2 @DJPaul
10 years ago

  • Keywords reporter-feedback added

What do you think the desired behaviour should be here with regard to deleted messages?

#3 @henrywright
10 years ago

Hi Paul,

This ticket isn't about deleted messages. It's about orphaned messages. i.e. message threads that were authored by a deleted user.

With reference to desired behaviour, I think things should be kept consistent as to how orphaned message threads are treated. For example, if they remain visible in a member's inbox and sentbox then they should also be returned in search results.

#4 @henrywright
10 years ago

  • Keywords reporter-feedback removed

#5 @imath
10 years ago

  • Keywords reporter-feedback added

Hi @henryright

Maybe i do not follow the same steps you did, because using BuddyPress 1.9-beta2 (latest trunk) and testing by deleting a user from the front end and another one from the backend, i didn't manage to reproduce..

In both case :

  • message are still in inbox or sent in case a user replied to the deleted user
  • when searching, the messages still show
  • opening the message indicates from "Deleted user".

See attached screencap (search-deleted-message.png).

#6 follow-up: @henrywright
10 years ago

Hi @imath

Thanks for testing this!

I can confirm your observations. I just tested in 1.9 beta 2 and got the exact results you did. Either a) the issue is resolved in 1.9 beta 2 or b) my original tests (which were done in an earlier version of BP) weren't valid.

Either way, this ticket can be marked as invalid as everything is working as expected now. Thanks again @imath

#7 @henrywright
10 years ago

  • Keywords reporter-feedback removed
  • Resolution set to invalid
  • Status changed from new to closed

#8 in reply to: ↑ 6 @imath
10 years ago

Replying to henrywright:

Thanks again @imath

You're welcome ;)

#9 @johnjamesjacoby
10 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.