Skip to:
Content

BuddyPress.org

Opened 10 years ago

Closed 10 years ago

#5217 closed defect (bug) (no action required)

Activity page not display links related my website

Reported by: gencharitaci's profile gencharitaci Owned by:
Milestone: Priority: normal
Severity: normal Version: 1.8.1
Component: Core Keywords: reporter-feedback
Cc:

Description

I have interesting bug in buddypress.
it doesnt update activity page if any user share a link including my website. But buddypress shows other updates not including my website link.

Important Note: I have tried 1.9 trunk versiyon before getting this error.

I will give you an example.

  1. I have shared link of my twitter account on activity page and it is posted there.

Before posting update (not including my website links)
http://oi40.tinypic.com/funlu8.jpg

After posting update and shows update in activity feed (SUCCESSFUL - not including my website links)
http://oi42.tinypic.com/2di4t9u.jpg

  1. I have shared a page link of my website, it says posted update but doesnt display on activity page

Before posting update (including my website links)
http://oi40.tinypic.com/34e5df7.jpg

After posting update but doesnt shows in activity feed (UNSUCCESSFUL - it is including my website links)
http://oi43.tinypic.com/rutnyv.jpg

Attachments (4)

after2.JPG (34.9 KB) - added by gencharitaci 10 years ago.
before2.JPG (35.5 KB) - added by gencharitaci 10 years ago.
after.JPG (33.5 KB) - added by gencharitaci 10 years ago.
before.JPG (34.6 KB) - added by gencharitaci 10 years ago.

Download all attachments as: .zip

Change History (8)

@gencharitaci
10 years ago

@gencharitaci
10 years ago

@gencharitaci
10 years ago

@gencharitaci
10 years ago

#1 @boonebgorges
10 years ago

  • Keywords reporter-feedback added

Do the updates show up after you hit the Refresh button in your browser? (In other words, is this just a Javascript problem, or are the updates not being saved to your database?)

Are you running any spam-prevention plugins that might be blocking updates with given links? Check Dashboard > Activity > Spam to make sure that the items are not being sent to spam.

#2 @gencharitaci
10 years ago

Ok. I found it now on Dashboard > Activity > Spam

Says: Assigned as spam by Akismet

But still assign all updates as spam, how can i solve this?

#3 @gencharitaci
10 years ago

Ok. I found it now on Dashboard > Activity > Spam and updates there and says : Assigned as spam by Akismet

But still assign all updates as spam, how can i solve this?

#4 @DJPaul
10 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Yes, this is expected behaviour.

Just before an activity item is saved to the DB, if Akismet integration is active, we ask Akismet if it thinks its spam. Due to the legacy JavaScript that powers BuddyPress' templates at the moment not being that great, there are a few edge cases where it thinks any return value from the JavaScript call is always a success message, so we can't show a message in this situation saying that "something's gone wrong".

It's something that we definitely need to improve on, and this specific thing is likely to improve in 2.0 or 2.1, as we start to replace legacy templates.

Can't comment on why Akismet things your messages might be spam, but I'd suggest encouraging users to post longer + more meaningful messages, or not include URLs. If your site requires these very short messages with URLs, the easiest immediate action you can take is probably to disable the activity Akismet integration. I wrote a plugin that does this: https://wordpress.org/plugins/disable-activity-akismet/

Thanks for reporting this issue out to us, and I'm sorry it took so long for us to wrap this up with you.

Note: See TracTickets for help on using tickets.