Skip to:
Content

BuddyPress.org

Opened 7 years ago

Closed 6 years ago

#5203 closed defect (bug)

BP Notice in Theme Customizer

Reported by: ericlewis Owned by:
Milestone: Priority: normal
Severity: normal Version: 1.5
Component: Administration Keywords:
Cc:

Description

BuddyPress throws a notice within the theme customizer screen in the admin.

BuddyPress seems to think here that WordPress core is jumping the gun on setting up the current user. This goes back to r6765. I'd like to hear more specifics about roles/caps issues that could come from this, are there any peculiarities specific to BP that would be caused by this? WP core seems to have no problem issuing current_user_can() checks pre-after_setup_theme - in the customizer, these checks are hit on the setup_theme hook.

Attachments (1)

Screen Shot 2013-10-14 at 11.31.43 PM.png (390.2 KB) - added by ericlewis 7 years ago.

Download all attachments as: .zip

Change History (7)

#1 @ericlewis
7 years ago

Simple solution here would be to change the hook checked in bp_setup_current_user() to 'setup_theme,' which fires directly after the global $wp_roles is declared. I don't see anything that happens between 'setup_theme' and 'after_setup_theme' that would affect roles or caps.

#2 @ericlewis
7 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #WP24169

#3 @r-a-y
7 years ago

  • Milestone Awaiting Review deleted

#4 @DJPaul
6 years ago

  • Milestone set to Future Release
  • Resolution duplicate deleted
  • Status changed from closed to reopened
  • Version changed from 1.8.1 to 1.5

This was never fixed; it doesn't look like it was looked at much.

#5 @DJPaul
6 years ago

Didn't find this earlier; closing in favour of #6046 because there's a patch on that.

#6 @DJPaul
6 years ago

  • Milestone Future Release deleted
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.