Skip to:
Content

BuddyPress.org

Opened 11 years ago

Closed 10 years ago

#5182 closed defect (bug) (no action required)

Crop function not working

Reported by: mugwumpman's profile mugwumpman Owned by:
Milestone: Priority: normal
Severity: normal Version: 1.8.1
Component: Core Keywords:
Cc:

Description

My installation of BuddyPress is able to upload images using the avatar system, but is impaired by a cropping bug. Chrome's devtools show that most of the elements are dynamically sized to be 0px by 0px. (If you resize them manually, they revert back to 0x0 as soon as you click anything)

You can see the preview window with the tiny crop-handles to the left of it in this screenclipping:
http://ccderbys.mishmedia.co.uk/cropbug.jpg

I'm using Buddypress 1.8.1 on Wordpress 3.6.1 with a custom-made child-theme of twentythirteen.

Switching to the twentythirteen theme fixes the bug, so it seems to be a conflict with the child-theme files, and to further narrow down the cause of the problem I've tried temporarily deleting each file in the child-theme folder, to find the only time the bug fixes is when I delete the stylesheet.

However there are no rules concerning the jcrop elements in the stylesheet, so does this suggest that the issue lies with how BuddyPress uses 'stylesheet_directory' vs 'theme_directory' in it's coding?

Here's a link to the test site, and thanks so much for any help.

mugwumpman

Change History (3)

#1 @r-a-y
11 years ago

Switching to the twentythirteen theme fixes the bug, so it seems to be a conflict with the child-theme files, and to further narrow down the cause of the problem I've tried temporarily deleting each file in the child-theme folder, to find the only time the bug fixes is when I delete the stylesheet.

There's some inline CSS that BuddyPress adds on the avatar cropper page:
http://buddypress.trac.wordpress.org/browser/tags/1.8.1/bp-core/bp-core-cssjs.php#L115

The problem probably lies in your child theme's CSS overriding the cropper somehow.

To check for sure, fire up your browser's debugger. (In your case, Chrome's). And try to find what CSS rules are taking precedence.

#2 @henrywright
11 years ago

Are you including jQuery twice? Twice stops the cropper from working. I ran into this exact problem today.

#3 @DJPaul
10 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

As best we know, the image cropper is currently working OK. This issue comes up from time to time and is usually related to a conflict with another JS script. We can definitely improve how we do things in future releases.

@mugwumpman If you still have this problem, please can you check your web browser's javascript console like @r-a-y said? We need that information to be able to investigate the problem. Thank you.

Closing ticket for now as no response from reporter in 3 months.

Note: See TracTickets for help on using tickets.