Skip to:
Content

BuddyPress.org

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#5178 closed defect (bug) (duplicate)

Certain custom permalinks with enabled root profiles results in a blank page

Reported by: henrywright Owned by: johnjamesjacoby
Milestone: Priority: normal
Severity: normal Version: 1.8.1
Component: Route Parser Keywords:
Cc:

Description

When I use the following custom permalink settings

/%author%/%post_id%/

and enable root profiles

define ( 'BP_ENABLE_ROOT_PROFILES', true );

I find that when visiting a blog post even though the URL will read something like example.com/username/615, I get a blank page with "Members" as the page title.

Change History (4)

#1 @henrywright
6 years ago

Just to add, by blank page I don't mean a white page of death - I mean I get a page styled properly BUT instead of getting the post content displayed, all I get is "Members" as the page title and "Members" as the page heading.

#2 @boonebgorges
6 years ago

  • Owner set to johnjamesjacoby
  • Status changed from new to assigned

Thanks for reporting this, henrywright. I'm not surprised to hear it's an issue.

I have a feeling that this is going to become moot once BP has adopted true rewrite rules (though I'm not totally sure how we'll resolve issues with BP_ENABLE_ROOT_PROFILES). I'm assigning this to johnjamesjacoby for more advice.

#3 @DJPaul
6 years ago

  • Component changed from Core to Rewrite Rules
  • Milestone changed from Awaiting Review to Future Release

#4 @johnjamesjacoby
6 years ago

  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from assigned to closed

Rewrite rules should take care of this completely. Author archives are special cased in WordPress, so I'm anticipating some amount of complications. There is little we can do about this now unfortunately. We could check the default permalink structure, and try to dance around conflicts in cases like this, but different permutations will quickly rabbit hole us into circumventing something that we have plans to correctly fix.

I'm going to close this as a duplicate of #4954, knowing it will be addressed once rewrite rules are playing nicely.

Note: See TracTickets for help on using tickets.