Skip to:
Content

BuddyPress.org

Opened 9 years ago

Closed 9 years ago

#5142 closed defect (bug) (duplicate)

class BP_Theme_Compat current_theme_supports('buddypress') check runs too early

Reported by: hnla's profile hnla Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Core Keywords:
Cc: hnla

Description

It might be the case that the check for theme_support in 'class BP_Theme_Compat' might be running too early to get a value returned.

If one accepts that theme setup functions should be run on the 'after_setup_theme' hook then adding add_theme_support('buddypress') on this hook will not be found move it outside the hook and the check does return true and we do bail out of the class correctly.

Change History (1)

#1 @r-a-y
9 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Thanks for the bug report, hnla!

Going to mark this as a duplicate of #4879 as that ticket already has some comments on it.

Note: See TracTickets for help on using tickets.