Skip to:
Content

Opened 8 months ago

Closed 2 months ago

#5140 closed defect (bug) (duplicate)

request membership inside of private group gives 404

Reported by: wdfee Owned by:
Milestone: Priority: normal
Severity: normal Version: 1.8.1
Component: Groups Keywords:
Cc: info@…

Description

hello,
when requesting membership out of a private group the user is sent to the 404 page, no request was sent. requesting out of the group directory works.

I didn't test 1.8 on this, maybe the issue came with this version. Of course I already deactivated all plugins and choose bp default theme. WP 3.6

Change History (6)

comment:1 wdfee8 months ago

  • Cc info@… added
  • Keywords has-patch reporter-feedback added

It's caused by the following: in bp-groups-screens.php function groups_screen_group_request_membership() the request is done if ( isset( $_POST['group-request-send']) ). But the $_POST variable is empty because it's a pure link button. I commented out line 471 and 483 (closing of the condition) - now it works.

comment:2 DJPaul8 months ago

  • Keywords has-patch removed

How exactly are you requesting membership of the private group? Can you go through step-by-step, and provide example URLs if possible?

I've just tried recreating this and wasn't able to.

comment:3 DJPaul4 months ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Closing issue as no feedback from reporter, and we need more details on how to recreate this issue.

comment:4 shanebp3 months ago

  • Keywords needs-testing added
  • Resolution invalid deleted
  • Status changed from closed to reopened

comment:5 imath3 months ago

ok i've managed to reproduce, i'll carry on on this ticket #5357 as it contains a patch

comment:6 DJPaul2 months ago

  • Keywords needs-testing removed
  • Resolution set to duplicate
  • Status changed from reopened to closed

Closing as a duplicate of #5357 as that has a patch.

Note: See TracTickets for help on using tickets.