Skip to:
Content

Opened 11 months ago

Closed 5 months ago

#5044 closed enhancement (fixed)

Old avatars not deleted

Reported by: henrywright Owned by: boonebgorges
Milestone: 1.9 Priority: normal
Severity: normal Version:
Component: Core Keywords: needs-patch
Cc:

Description

If a member changes their avatar, the old avatar remains in the avatar directory (wp-content/uploads/avatars/). There is no way for the member to reuse the old avatar so it is completely redundant and just takes up space on the server.

Change History (8)

comment:1 henrywright11 months ago

  • Type changed from defect (bug) to enhancement

comment:2 boonebgorges10 months ago

  • Keywords needs-patch added; avatars removed
  • Milestone changed from Awaiting Review to Future Release

Good catch. Should be an easy fix for someone who wants props :)

comment:3 sbrajesh10 months ago

This is not a bug anymore in BuddyPress 1.8 trunk.

comment:4 henrywright8 months ago

Tested in 1.8.1 and as @sbrajesh mentioned this has been resolved.

comment:5 henrywright8 months ago

  • Resolution set to fixed
  • Status changed from new to closed

comment:6 DJPaul8 months ago

  • Milestone changed from Future Release to 1.8

comment:7 boonebgorges5 months ago

  • Milestone changed from 1.8 to 1.9
  • Resolution fixed deleted
  • Status changed from closed to reopened

This was not actually fixed. See #5242.

comment:8 boonebgorges5 months ago

  • Owner set to boonebgorges
  • Resolution set to fixed
  • Status changed from reopened to closed

In 7572:

Delete user avatar on user deletion.

Fixes #5044. Fixes #5242.

Note: See TracTickets for help on using tickets.