Skip to:
Content

BuddyPress.org

Opened 11 years ago

Closed 10 years ago

#5024 closed defect (bug) (no action required)

Global.js ID ref prevents joining private group in single group view

Reported by: becskr's profile becskr Owned by:
Milestone: Priority: normal
Severity: normal Version: 1.7
Component: Groups Keywords: reporter-feedback needs-patch
Cc:

Description

Users wanting to join a private group can only do so in the group directory as global.js line 940 references an id which is only listed on the groups directory

jq('#groups-dir-list').on('click', '.group-button a', function() {

If the user is in single group mode, depending on what browser you are in either returns to the page and the button still says "Request membership" or 404's

I added additional function to reference #item-buttons instead of groups-dir-list but really could just do with referencing .group-button a instead.

Change History (5)

#1 @boonebgorges
11 years ago

  • Keywords reporter-feedback added

This is probably caused by r6973. See #4931 for the reason we can't just change the selector back to '.group-button a'.

You are correct that r6973 breaks AJAX group membership requests from the single group page. It's no problem to change the delegation so that it covers single group pages. However, I'm finding that I'm still able to join and request membership on single pages, albeit without the use of AJAX. Specifically: on the single page of a private group, click the Request Membership button in the group header; you are then led to the Request Membership tab, where you fill in an optional message and then submit; the request is then sent and you're redirected back to the group home page with a success message.

You're reporting that you're getting immediate redirects/404s depending on browser. Could you please be more specific about exactly what you're doing, exactly what you're seeing, and how it differs between browsers? I would like to be able to reproduce your issue before putting in a fix.

Thanks!

#2 @johnjamesjacoby
11 years ago

  • Component changed from Core to Groups
  • Keywords needs-patch added
  • Milestone changed from Awaiting Review to 1.8.1

Probably a regression introduced around 1.7. Should be fixed, but too close to 1.8 release to tweak this behavior. Moving to 1.8.1 so we can dedicate some time towards fixing it after 1.8.

#3 @johnjamesjacoby
11 years ago

  • Milestone changed from 1.8.1 to 1.9

No reported feedback, so bumping to 1.9 for future investigation.

#4 @r-a-y
11 years ago

For the 404 issue, might be related to the server.

I recently ran into problems with nonced URLs in general because the server was running nginx and the rewrite rules were not set up properly. As a result, the $_REQUEST['_wpnonce'] did not exist, but existed in $_REQUEST['q'] = '_wpnonce=xxxx'.

This led to the nonce failing and 404 and redirects started happening. Just a FWIW.

#5 @boonebgorges
10 years ago

  • Milestone 1.9 deleted
  • Resolution set to invalid
  • Status changed from new to closed

Closing due to lack of reporter feedback. If you are continuing to have problems, please share some of the details requested above. Thanks!

Note: See TracTickets for help on using tickets.