Skip to:
Content

BuddyPress.org

Opened 7 years ago

Closed 6 years ago

#4909 closed defect (bug) (duplicate)

Theme compat doubles the_content when using AddThis

Reported by: offgridpro Owned by:
Milestone: 1.8 Priority: normal
Severity: minor Version:
Component: Core Keywords:
Cc:

Description (last modified by boonebgorges)

On every BP page (default settings), there is a doubling of page content.

[Edit: Only when using AddThis. See https://buddypress.trac.wordpress.org/ticket/4909#comment:11]

Change History (12)

#1 @boonebgorges
7 years ago

  • Keywords reporter-feedback added

Please provide adequate information to allow us to reproduce this reported issue.

  • A more complete description of the actual problem (what is "every BP page", what is "doubling", what is "page content"). Screenshots or links would be helpful
  • BP, WP versions
  • Theme being used
  • Other plugins installed

#2 @offgridpro
7 years ago

  • This is a new website with a fresh installation of BP 1.7.
  • I am using WP 3.5.1
  • I purchased a theme from Woo Themes (WhiteLight), and modified it to look as I wanted.

Other plugins being used:

  • AddThis Social Bookmarking Widget (v 3.0.5)
  • Akismet (v 2.5.7)
  • bbPress (v 2.2.4)
  • Blubrry PowerPress (v 4.0.7)
  • BuddyPress (v 1.7-rc1)
  • Disqus Comment System (v 2.74)
  • Google Analytics for WordPress (v 4.3.2)
  • W3 Total Cache (v 0.9.2.8)
  • WooDojo (v 1.5.2)
  • WooSidebars (v 1.2.2)
  • WordPress Importer (v 0.6.1)
  • WordPress SEO (v 1.4.4)
  • WordPress SEO News (v 1.1.1)

When I installed BP, I immediately went to see how it looked on the front-end. I noticed entire sections of duplicate content displaying on all the BP related pages. As if some copied/pasted huge chunks of HTML.

Affected URLs:

I love what you guys have done in 1.7. Thank you in advance.

#3 @boonebgorges
7 years ago

Thanks very much for the additional information.

I'm pretty certain that this is a theme-related issue, though I'm not 100% sure of the exact cause. As a test, could you please try switching your theme to a default WP theme (Twenty Twelve would be a good test) to see if the problem goes away?

If so, I may ask you to email me a copy of the theme (plus your modifications) so that I can have a quick look. It's possible that it's doing something funky with the_content().

#4 @offgridpro
7 years ago

I changed the theme to Twenty Twelve, and Tenty Eleven... No luck. Same issue. i also tried deactivating some of the plugins I have installed, to see if one of them is messing with the_content()... Still no luck.

I can email you a copy of the Woo theme, but I doubt it is theme-related now, and the only changes I made were to the custom.css.

Let me know how you'd like to proceed. Thank you!

#5 @r-a-y
7 years ago

What happens when you disable W3 Total Cache?

#6 @offgridpro
7 years ago

I just deactivated it (you can see the same links with it deactivated. The problem remains...

I haven't tried disabling ALL plugins yet. Would that help you narrow the culprit? Thanks!

#7 @boonebgorges
7 years ago

I doubt it is theme-related now

I agree, but it has to be a problem with your specific setup, because I (and afaik no one else) has experienced the problem. That's not to say it's your fault :) just that it's got to be due to a specific configuration.

Please do try deactivating all plugins.

Is this an upgrade from a previous installation of BP?

#8 @offgridpro
7 years ago

No... I waited -- and waited :) -- for 1.7 because I didn't want to mess with any migration headaches.

I host with Page.ly, so I never personally installed WP. They are a WP specialist (especially with security updates), so I felt confident that all my decisions were sound with regards to reputable plugins, solid hosting, etc.

I just deactivated everything but BP and bbPress... FIXED!

Now I just need to turn them on, one-by-one to find the culprit. I suspect when I do, I would need to take that up with the plugin developer, right? Do you guys have any interest beyond this point?

Thanks!

#9 @offgridpro
7 years ago

Found the culprit... AddThis Social Bookmarking widget. I'm digging in now to see what may have caused that issue.

#10 @offgridpro
7 years ago

I pared down the AddThis settings to the bare minimum, and still experienced the "doubling" bug. So this is something I'll bring up with the AddThis team. In the meantime, I guess I need another social sharing solution.

Any battle-tested plugins you can recommend with 1.7? Thanks!

#11 @boonebgorges
7 years ago

  • Description modified (diff)
  • Keywords 2nd-opinion added; reporter-feedback removed
  • Milestone changed from Awaiting Review to 1.8
  • Severity changed from normal to minor
  • Summary changed from Double display issues on nearly every page to Theme compat doubles the_content when using AddThis

Thanks for your detective work, offgridpro. I've downloaded AddThis and reproduced the problem.

The issue is that AddThis is doing something funky to the_content, and they're doing it *after* other filters have run. You can temporarily fix the problem by finding the following line in addthis/addthis_social_widget.php (around 1067):

        add_filter('the_content', 'addthis_display_social_widget', 15);

and changing the number 15 to something less than 10, eg

        add_filter('the_content', 'addthis_display_social_widget', 5);

It's possible that we could do a better job avoiding these kinds of conflict in BuddyPress. I'm moving this ticket to 1.8 so the dev team can discuss.

#12 @r-a-y
6 years ago

  • Keywords 2nd-opinion removed
  • Resolution set to duplicate
  • Status changed from new to closed

The patch in #5021 solves this issue; I'm going to close this one as a duplicate.

Note: See TracTickets for help on using tickets.