Skip to:
Content

BuddyPress.org

Opened 11 years ago

Closed 11 years ago

#4886 closed defect (bug) (worksforme)

Groups Forums display the same topic throughout all group forums

Reported by: limitx3m's profile limitx3m Owned by: limitx3m's profile limitx3m
Milestone: Priority: normal
Severity: normal Version: 1.7
Component: Groups Keywords: reporter-feedback
Cc:

Description

I'm using the beta 2 and the latest (non-bleeding) bbpress.

When I make/move a thread in any group forum (new, old, etc.) it displays in all group forums.

I can't tell if this is a buddypress issue, and that it's displaying the forum topics incorrectly or a bbpress issue. I've posted to both and have attached a screenshot.

In the screenshot you can see two topics/threads that were created in separate group forums, but it exists in all forums.

Last time I made a thread in both areas it was ignored/closed. The problem still exists.

Attachments (3)

wpcrap.tiff (120.3 KB) - added by limitx3m 11 years ago.
offtopic.jpg (119.9 KB) - added by limitx3m 11 years ago.
relationships.jpg (127.3 KB) - added by limitx3m 11 years ago.

Download all attachments as: .zip

Change History (9)

@limitx3m
11 years ago

#1 @boonebgorges
11 years ago

  • Keywords reporter-feedback added

Could you please attach another screenshot? This one doesn't work.

@limitx3m
11 years ago

#2 @limitx3m
11 years ago

Sorry. Mac does .tiff as default on screenshots.

Anyways, the same threads will list in every group. :(

#3 @boonebgorges
11 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

I can't reproduce this problem using the latest BP trunk + bbPress 2.2.4 (which is, I assume, what you're running).

It could be that you have a plugin or theme conflict. Or perhaps this installation is migrated from a previous installation of bbPress 1.x, and you didn't properly run the import tools. See http://codex.buddypress.org/user/setting-up-a-new-installation/installing-group-and-sitewide-forums/using-bbpress-2-2-with-buddypress/ for more details.

If you continue to experience problems, please open a ticket at bbPress's Trac, so that the correct people see your report. If you do so, please provide as many details as possible about your setup (specific WP/BP/bbPress versions, themes and plugins running, whether your site is new or upgraded from a previous site, when the issue started happening, specific steps to reproduce). Thanks.

#4 @limitx3m
11 years ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened

It looks like the issue can be created by:

  1. Converting my vbulletin database to bbpress (2,000 users, 100k topics)
  2. Turning on buddypress
  3. Make a new parent forum for the groups. ( Usually called it “The Nation”)
  4. Select group forums to be placed in “The Nation” in the buddypress options
  5. Create 2 groups.
  6. Move/create topic in each group.

You will see each group will share the same topics. If I make a new group, that group will have all the topics of the previous groups.

It’s not duplicating the topics, but rather the group forums just contain every thread from other group forums.

I have been testing everything for months with brand new installs, converting my database over several times with each release. The issue is consistent no matter which version.

I’d be happy to work with someone so that we can figure out the issue.

BBpress 2.3-rc1
Buddypress 2.7 beta 2
Wordpress 3.5.1
Multi site

#5 @limitx3m
11 years ago

Also, the database seems to convert well and bring in all my users and topics. I’m not sure how the conversion would cause this issue.

I’ve posted this on the bbpress trac here:

Topic is also posted on the bbpress trac here:
https://bbpress.trac.wordpress.org/ticket/2293

I’m not sure whether or not it’s a bbpress issue or a buddypress issue and I keep getting sent all over the place.

#6 @boonebgorges
11 years ago

  • Resolution set to worksforme
  • Status changed from reopened to closed

Thanks for the update. The fact that it's happening with something you migrated from vbulletin makes me think it's almost certainly a problem with the bbPress importer, and not a problem that's specific to the BuddyPress interface. Since you've posted all your information over at bbPress Trac, and since I dont want conversation to fracture between these two tickets, I'm going to reclose this ticket. If it turns out that this is indeed a BP-specific issue, please feel free to reopen. Thanks.

Note: See TracTickets for help on using tickets.