Skip to:
Content

BuddyPress.org

Opened 11 years ago

Closed 10 years ago

Last modified 9 years ago

#4882 closed defect (bug) (duplicate)

Updating Permalinks Breaks Navigation

Reported by: beeeerock's profile beeeerock Owned by: johnjamesjacoby's profile johnjamesjacoby
Milestone: Priority: normal
Severity: normal Version: 1.7
Component: Route Parser Keywords: needs-patch
Cc:

Description

1.7Beta2. Unzipped download into plugins directory of a simple site using P2 Theme. Activated plugin. Went to Settings, BuddyPress and see the three tabbed screen for configuring BuddyPress. At the top I see, with a yellow background: "BuddyPress is almost ready. You must update your permalink structure to something other than the default for it to work."

I should note, the P2 site was working and had two pages. Menu functioned fine with the default permalink structure. At this point, with BP just activated, BP menu additions are present and link without error to the new (blank) pages. However, they are blank pages and there is no expected content ('register' for instance should have something registration-related one would assume!), so BP is not functioning, as the yellow warning would suggest.

Selecting a different permalink structure and saving removes the yellow warning from the top, but after a refresh I get 404 errors from the menu items (all except the original 'blog' which is a 'custom' item in the menu configuration page).

It should be noted that this is an intranet site, called 'testblog'. DNS internally knows to direct 'testblog' requests to this server. So the web browser address simply shows 'testblog/wordpress/' for the home blog page. I don't know if this somehow breaks the permalink structure, or if something else must be done to make it work on an existing P2 site. Or P2 breaks it.

Not other plugins running, except akismet.

Change History (7)

#1 @johnjamesjacoby
11 years ago

  • Component changed from Core to Rewrite Rules
  • Keywords needs-patch added
  • Milestone changed from Awaiting Review to 1.8
  • Owner set to johnjamesjacoby
  • Status changed from new to assigned

BuddyPress requires that pretty permalinks be setup and working correctly, using PHP's mod_rewrite module. We're going to address this requirement in 1.8, so moving this ticket there.

Related: #2086.

#2 @beeeerock
11 years ago

You're absolutely right, it was the mod_rewrite module I figured out after messing with .htaccess and apache directory settings. Adding a sanity check to 1.8 would save other less-savvy users like myself the headaches. Thanks!

#4 @boonebgorges
11 years ago

  • Milestone changed from 1.8 to 1.9

#5 @r-a-y
10 years ago

  • Milestone changed from 1.9 to 2.0

#6 @johnjamesjacoby
10 years ago

  • Milestone 2.0 deleted
  • Resolution set to duplicate
  • Status changed from assigned to closed

Closing this as a duplicate of #4954.

#7 @johnjamesjacoby
9 years ago

  • Version changed from 1.7-beta to 1.7
Note: See TracTickets for help on using tickets.