Skip to:
Content

BuddyPress.org

Opened 9 years ago

Closed 9 years ago

#4872 closed enhancement (fixed)

Filtering with "my favorites"

Reported by: chroniko Owned by: boonebgorges
Milestone: 1.8 Priority: low
Severity: normal Version: 1.7
Component: Activity Keywords: has-patch needs-unit-tests needs-testing
Cc:

Description

The drop down list filter (everything, updates, posts, comments, etc) on “My Favorites” tab doesn’t work. It always show all my favorite activities. The filter with other tabs do work fine.

Attachments (1)

4872.diff (512 bytes) - added by chroniko 9 years ago.

Download all attachments as: .zip

Change History (3)

@chroniko
9 years ago

#1 @boonebgorges
9 years ago

  • Component changed from Core to Activity
  • Keywords needs-unit-tests needs-testing added
  • Milestone changed from Awaiting Review to 1.8
  • Priority changed from normal to low
  • Type changed from defect (bug) to enhancement

Duplicate of #4851. I'll close that one in favor of this, since you've provided a patch.

#2 @boonebgorges
9 years ago

  • Owner set to boonebgorges
  • Resolution set to fixed
  • Status changed from new to closed

In 6926:

In bp_has_activities(), allow 'favorites' to be filtered by 'Show' dropdown

Switching the 'favorites' logic to interpret the favorite ids as part of the
'in' parameter rather than the 'include' paramater allows other filter params,
including those in the 'Show' dropdown on activity directories (the 'action'
parameter of bp_has_activities()) to work.

Fixes #4872

Props chroniko

Note: See TracTickets for help on using tickets.