Skip to:
Content

BuddyPress.org

Opened 8 years ago

Closed 8 years ago

#4843 closed defect (bug) (fixed)

Are you Sure/Confirm action is not Run on BuddyPress 1.7 beta 1

Reported by: sbrajesh Owned by:
Milestone: 1.7 Priority: normal
Severity: major Version: 1.7
Component: Core Keywords:
Cc:

Description

Hi,
I am testing BuddyPress 1.7 beta 1 with standard WordPress(Not multisite) and I am using the bp-default theme.

The confirm actions are not run. If you click on delete activity the activity is deleted silently and the same goes for any action which requires confirmation(I haven't tested them all though).

The problem is in Bp 1.7, the check for click on confirm link is delegated to body while the activity delete is delegated to div.activity.

Since in event bubbling, the event is captured by the functions attached to div.activity before it reaches to body, no confirmation message is asked and the action gets completed silently.

It is a regression from Bp 1.6(1.6 had trouble showing the confirm message for elements loaded via ajax).

I will recommend that we revert the changes in bp_core_confirmation_js to the BP 1.6.x code unless there is a complete review of the included javascript for event delegations/priority.


Change History (2)

#1 @boonebgorges
8 years ago

  • Milestone changed from Awaiting Review to 1.7
  • Severity changed from normal to major

Confirmed. Thanks for the report, sbrajesh.

#2 @boonebgorges
8 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [6809]) Don't use event delegation in bp_core_confirmation_js()

Event bubbling prevents the JS confirm dialog from working properly.

This commit reverts changes introduced in #6597. See #4458

Fixes #4843. Props sbrajesh

Note: See TracTickets for help on using tickets.