Skip to:
Content

#4823 closed defect (bug) (invalid)

“BuddyPress Global Unified search” plugin error messages

Reported by: kraigg Owned by:
Milestone: Priority: normal
Severity: normal Version: 1.7
Component: Core Keywords:
Cc:

Description

BuddyPress Global Unified Search" plugin causes error message when browsing to non-BuddyPress pages (ie. pages created in WordPress).

Error message is ("Warning: strstr() [function.strstr]: Empty delimiter in ../wp-content/plugins/buddypress/bp-core/bp-core-template.php on line 864")

Attachments (1)

buddypress-1.7-trunk.jpg (8.2 KB) - added by kraigg 14 months ago.

Download all attachments as: .zip

Change History (9)

comment:1 r-a-y14 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Please contact the plugin author about this issue.

If the plugin author deems this to be a BP problem, feel free to reopen this ticket with some steps to reproduce.

Thanks!

comment:2 r-a-y14 months ago

  • Milestone set to Awaiting Review
  • Resolution invalid deleted
  • Status changed from closed to reopened

Sorry... just read the issue in further detail.

That portion of code is a little weird. Not sure why we're doing a check on the WP page template.

Reopening for further investigation.

comment:3 sbrajesh14 months ago

Just had a look.
The problem is caused by empty component slug being checked using the bp_is_current_component. The empty slug is an issue with global unified search.

But should not the function bp_is_current_component( $component ) return false if $component is empty or false.

I guess, we should really put a check for this.

comment:4 sbrajesh14 months ago

kraigg,
I have just pushed an update to the global unified plugin. Please use the latest version from here. It should fix the issue
https://github.com/sbrajesh/bp-global-unified-search

For Dev Team, We should put an if(empty($component)) return false; as the first line of bp_is_current_component to avoid this issue. But again, If it is there, It may not help developers to locate the empty component issue. So, I will take my last request back and will suggest to avoid putting anything like this and close this ticket.

comment:5 kraigg14 months ago

Thanks Brajesh for the quick update.

The errors are gone, but now the global unified search doesn't work. It is reverting back to the default BuddyPress search, with the dropdown list for members, groups, and posts.

Should I close this ticket and create a new ticket elsewhere?

comment:6 sbrajesh14 months ago

Hi Kraigg,
Let us close this ticket as the discussion is no more relevant to the BuddyPress but to that particular plugin.

I am looking at it and will post an update soon(Just testing at the moment). Can you please open a ticket on the github page ?

comment:7 sbrajesh14 months ago

Ok, just the final comment. The plugin will work if you followed the installation instructions and updated functions.php.

comment:8 r-a-y14 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from reopened to closed

Saw your commit on Github, Brajesh.

Closing this ticket. Feel free to reopen if needed.


This ticket did open my eyes to a weird bit of code though. For those that want to follow, here's the bit in question:
https://buddypress.trac.wordpress.org/browser/tags/1.6.4/bp-core/bp-core-template.php#L859

Not sure why we're checking for the WP page template when we're on a regular WP page. This might have something to do with BP's auto-created WP pages like "Register" and "Activate". Just thinking out loud.

Note: See TracTickets for help on using tickets.