Skip to:
Content

BuddyPress.org

Opened 7 years ago

Closed 7 years ago

#4805 closed defect (bug) (fixed)

groups page missing when activated

Reported by: intimez Owned by:
Milestone: 1.7 Priority: high
Severity: major Version: 1.7
Component: Core Keywords:
Cc:

Description

after installing buddypress and enabling all components:

activity, members, register, activate are all created automatically

but groups is not so it prompts users.

wordpress 3.5.1 and buddypress trunk-6767

Change History (2)

#1 @boonebgorges
7 years ago

  • Milestone changed from Awaiting Review to 1.7
  • Priority changed from normal to high

Confirmed.

This is not a regression, but is a case where a limitation in the design of bp-pages is being surfaced in the new, wizardless setup.

Three core BP components have directory pages: Members, Activity, and Groups. It's always been the case (since 1.5) that components activated after the wizard need to have directory pages created for them manually. It just so happens that, because all components were activated by default, few people ever stumbled upon this somewhat cumbersome experience.

Now we don't have a wizard, and directory pages are created automatically on installation. But since Groups is not one of the default components, it means that new BP installations will *always* have to manually create a Groups directory page when activating Groups. So, while before this was a minor annoyance for a small subset of users, it's now a hurdle for everyone who decides to try out BP Groups.

I'm going to tweak the way that the Components page works so that directory pages are automatically created when a new directory-having component is activated. In practice, this'll only affect Groups. IMO it's a bit annoying to be auto-creating pages, but we're already doing it during activation, and it's the lesser of two evils in this case (the other evil being the really annoying experience of having to create the page manually).

#2 @boonebgorges
7 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [6770]) Improvements to automatic WP page mapping for BP directory components

Since the wizard was removed, and Members and Activity were set as the default
components, BP has been creating directory pages for Members and Activity
automatically upon installation. This created a jarring disparity for the
Groups component, which also needs a top-level directory; when activated at a
later date, the user would be prompted to associate a page manually.

This changeset moves bp_updater_add_page_mappings() to the core component
(renaming it appropriately). This function is refactored to allow for existing
page mappings to be retained, as you'd want to do when activating new
components (rather than deleting existing mappings and mapped pages, as you'd
want during a fresh installation). Finally, the function is called when saving
the Components admin page, so that components requiring directory pages (like
Groups) get them created automatically upon activation.

Fixes #4805

Note: See TracTickets for help on using tickets.