Skip to:
Content

Opened 15 months ago

Closed 14 months ago

Last modified 14 months ago

#4801 closed defect (bug) (invalid)

Message Send To Autocomplete not working - 1.6.4

Reported by: NickMackz Owned by:
Milestone: Priority: normal
Severity: normal Version: 1.6.2
Component: Messaging Keywords: reporter-feedback
Cc:

Description

I don't think this has been working in the last couple of versions. Tested on a production site and on a test site.

Attachments (1)

autocomplete fails.png (33.2 KB) - added by mort3n 14 months ago.
FireBug view of BP Messages autocomplete fail

Download all attachments as: .zip

Change History (12)

comment:1 r-a-y15 months ago

  • Keywords reporter-feedback added

Are you using the bp-default theme?

Are you able to debug the javascript when it's firing? If you're using Firefox, try this tutorial with Firebug:
http://www.zyxware.com/articles/2642/debugging-tips-how-to-debug-ajax-requests-using-mozilla-firefox-and-firebug

Other browsers like Chrome and Safari have their own developer console; if you're familiar with them and are able to debug, please post your console log.


Keep in mind that, by default, you need to be friends with other users for autocomplete to work.

Last edited 15 months ago by r-a-y (previous) (diff)

comment:2 NickMackz15 months ago

I was using the Custom Community theme. Tested with firebug and no javascript fires at all.

Tested again in the bp-default theme and it is working. Is there a specific bit of code that I would need to add (or update) in the Custom Community theme to make it work?

Last edited 15 months ago by NickMackz (previous) (diff)

comment:3 NickMackz15 months ago

  • Keywords reporter-feedback removed

comment:4 petervandoorn15 months ago

Can confirm that this is happening with me too. WP 3.5.1 / BP 1.6.4 all other plugins deactivated and the default theme activated too.

comment:5 r-a-y14 months ago

  • Keywords reporter-feedback added

@NickMackz - The Custom Community devs will probably need to update a portion of their javascript.

They might want to look at this JS change in bp-default:
https://buddypress.trac.wordpress.org/changeset/6704/branches/1.6/bp-themes/bp-default/_inc/global.js

If they are using a copy of global.js, then that's probably the change that will help them.


@petervandoom - We need more details. Do you have any friends on your site? You need to have friends by default to use the autocomplete feature. Are you using the Events Manager plugin? (See #4824)

mort3n14 months ago

FireBug view of BP Messages autocomplete fail

comment:6 mort3n14 months ago

Setup WP 3.5.1 BP 1.6.4

wp-config contains

define( 'BP_MESSAGES_AUTOCOMPLETE_ALL', true );

Theme is bp-default

FireBug show attached issue

comment:7 boonebgorges14 months ago

Does the same thing happen when BP_MESSAGES_AUTOCOMPLETE_ALL is disabled?

comment:8 mort3n14 months ago

Friends component is not enabled, so the test would be void.
Am on live site.

comment:9 mort3n14 months ago

Update :

On my install, this was caused by plugin http://wordpress.org/extend/plugins/wordpress-https/. It works with version 3.3.0 but not with 3.3.5.

I apologise sincerely for not testing this properly before adding to this ticket!

Am looking forward to BP 1.7 :-)

comment:10 boonebgorges14 months ago

  • Resolution set to invalid
  • Status changed from new to closed

Thanks for the update, mort3n. Just a few days ago, a fix was committed to trunk that smooths the way that https is handled for AJAX. See #4761. So I'm guessing that your issue will be resolved with 1.7.

I'm closing this ticket, under the assumption that the other reporters were having similar issues. Please reopen if you have details to the contrary.

comment:11 boonebgorges14 months ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.