Skip to:
Content

BuddyPress.org

Opened 7 years ago

Closed 4 years ago

#4793 closed defect (bug) (no action required)

page not found when loggin out from a member's profile page

Reported by: chouf1 Owned by:
Milestone: Priority: normal
Severity: minor Version:
Component: Route Parser Keywords:
Cc:

Description

BP 1.6.4 (had the same trouble on 1.6.2 and 1.6.3)
wp 3.5.1 MS

as super-admin, i get a "page not found" error each time i logout from a member profile edit page -> membres/xxxx/profile/edit/group/1/

The logout should redirect to the homepage or to the profile activity

I tested this on a MS and a single WP/BP install. Single works fine, MS doesn't

on the Ms, the logout link looks like this

/wp-login.php?action=logout&redirect_to=http%3A%2F%2Fexample.com%2Fmembres%2Fxxxx%2Fprofile%2Fedit%2Fgroup%2F1&_wpnonce=cf3b944fa7

on the single install i have this (with wp_logout_url( home_url() ) on my template), who is working.

/wp-login.php?action=logout&redirect_to=http%3A%2F%2Fexample.com&_wpnonce=b1937f1b98

Apologize if this was already related.

Change History (3)

#1 @DJPaul
7 years ago

  • Keywords reporter-feedback added

Which log out link are you using? Where is it?

#2 @johnjamesjacoby
7 years ago

  • Milestone changed from Awaiting Review to Future Release

Not exactly a regression, and might be a duplicate. Basically, we need a smarter URL router, and we have one half-built in core already. Moving to future release, so we can address this in the long term, outside of 1.7/1.8.

#3 @mercime
4 years ago

  • Keywords reporter-feedback removed
  • Milestone Future Release deleted
  • Resolution set to invalid
  • Status changed from new to closed

@chouf1 As of BP 2.6 and BP 2.7 trunk, tested on both multisites as super admin and regular user. Logging out on both redirects me to login.php (xxxxxx.com/wp-login.php?loggedout=true)

Note: See TracTickets for help on using tickets.