Skip to:
Content

BuddyPress.org

Opened 9 years ago

Closed 4 years ago

#4774 closed enhancement (maybelater)

Autocomplete for Messages 'Send to' searches all xprofile fields

Reported by: mort3n Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Messages Keywords: needs-patch, trac-tidy-2018
Cc:

Description

In Messages, field Send to:

Searching all members by

define( 'BP_MESSAGES_AUTOCOMPLETE_ALL', true );

Searches all fields in xprofile data table through

BP_Core_User::search_users()

This often leads to irrelevant results (e.g. type John finds Grace living on John Street).

Expected behaviour is to search only valid information i.e. user names and display names.

PS. Using 1.6.3, but can't choose that version in dropdown below this textfield.

Change History (6)

#1 @mort3n
9 years ago

Can use filter

bp_core_search_users_sql

Still, it makes sense to return expected data as default.

#2 @DJPaul
9 years ago

  • Milestone changed from Awaiting Review to Future Release

#3 @slaFFik
5 years ago

  • Component changed from Core to Messages
  • Keywords dev-feedback added
  • Version 1.6.1 deleted

I can replicate the issue, we search for xprofile fields, that might be not very relevant.

As I can see in the code - we do that regardless of BP_MESSAGES_AUTOCOMPLETE_ALL value. For friends (when const is not defined, and in case xprofile is activated) we do absolutely the same.

So we need to decide - whether we want/need to rewrite the search here to make it search by user_name, display_name and other names (but exclude profile data), or leave as is.

#4 @boonebgorges
5 years ago

  • Keywords needs-patch added; dev-feedback removed

We probably can't rewrite the way the current search works - it's likely the same code that's used for directory searches, which arguably *should* look at all xprofile fields - but we should add a separate search method for name-fields only.

#5 @DJPaul
4 years ago

  • Keywords trac-tidy-2018 added

We're closing this ticket because it has not received any contribution or comments for at least two years. We have decided that it is better to close tickets that are good ideas, which have not gotten (or are unlikely to get) contributions, rather than keep things open indefinitely. This will help us share a more realistic roadmap for BuddyPress with you.

Everyone very much appreciates the time and effort that you spent sharing your idea with us. On behalf of the entire BuddyPress team, thank you.

If you feel strongly that this enhancement should still be added to BuddyPress, and you are able to contribute effort towards it, we encourage you to re-open the ticket, or start a discussion about it in our Slack channel. Please consider that time has proven that good ideas without contributions do not get built.

For more information, see https://bpdevel.wordpress.com/2018/01/21/our-awaiting-contributions-milestone-contains/
or find us on Slack, in the #buddypress channel: https://make.wordpress.org/chat/

#6 @DJPaul
4 years ago

  • Milestone Awaiting Contributions deleted
  • Resolution set to maybelater
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.