Skip to:
Content

Opened 15 months ago

Closed 12 months ago

Last modified 12 months ago

#4771 closed defect (bug) (duplicate)

Show the Toolbar for logged out users | Toolbar not showing no matter what

Reported by: magichew Owned by:
Milestone: 1.7 Priority: normal
Severity: normal Version: 1.7
Component: Core Keywords: has-patch
Cc:

Description

No matter whether checked or not checked the Toolbar doesn't show to logged out users.

Attachments (1)

4771.01.patch (1021 bytes) - added by r-a-y 15 months ago.

Download all attachments as: .zip

Change History (10)

comment:1 r-a-y15 months ago

  • Keywords has-patch added
  • Milestone changed from Awaiting Review to 1.7

Confirmed.

According to the WP codex article, show_admin_bar() should be run on plugin loaded.

I've attached a patch that moves the BP admin bar loading from 'bp_init' to 'bp_loaded' and that fixes things.

r-a-y15 months ago

comment:2 magichew15 months ago

Patch applied and working.

comment:3 DJPaul15 months ago

  • Keywords commit added

comment:4 r-a-y15 months ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [6724]) Fix 'Show the Toolbar for logged out users' setting.

bp_core_load_admin_bar() uses the show_admin_bar() function; this
function toggles the WP toolbar visibiility.

WP recommends to use show_admin_bar() on 'plugins_loaded':
https://codex.wordpress.org/Function_Reference/show_admin_bar#Notes

Therefore, this commit changes when bp_core_load_admin_bar() runs
from 'bp_init' to 'bp_loaded'.

Fixes #4771.

comment:5 magichew14 months ago

I understand that you guys are perhaps still figuring this one out but I just wanted to let you all know that this hasn't been patched in the 1.7 beta 1. I've had to manually added the patch again after updating.

comment:7 magichew12 months ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

Hello. Sorry to keep going on about this but this issue still persists in the release version. I had to manually add the patch to make the bar appear.

comment:8 r-a-y12 months ago

  • Keywords commit removed
  • Resolution set to duplicate
  • Status changed from reopened to closed

Closing in favor of #4803 since that ticket is more current and has an updated patch.

magichew: Try the patch in #4803.

comment:9 magichew12 months ago

Okay. Will do. Thanks r-a-y

Note: See TracTickets for help on using tickets.