Skip to:
Content

BuddyPress.org

Opened 7 years ago

Closed 6 years ago

#4741 closed enhancement (fixed)

Provide different URLs for each anchor!

Reported by: jidanni Owned by: boonebgorges
Milestone: 1.8 Priority: normal
Severity: normal Version:
Component: Activity Keywords:
Cc:

Description

I can't believe the most precision one can get is "p/1751/",

$ lynx -dump -listonly http://www.bdsm.com.tw/groups/self-introduction/ |
  perl -nwle 's/.*\d+\. (.*activity)/$1/&&print'|sort|uniq -c|sort -n|tail -n 3
      3 http://www.bdsm.com.tw/activity/p/1603/
      9 http://www.bdsm.com.tw/activity/p/1736/
     12 http://www.bdsm.com.tw/activity/p/1751/

Compare that to Facebook where every item has its precise anchor,
here on Buddypress the best URL to a certain comment would just lead the user to the whole "p/1751/" page...

So no more sharing links to "what Bob said", as the reader would have to guess where on the giant page you were hoping he was to take a look at.

"Oh, what Bob said".

Well Bob said seveal things, which one?

Who knows, because there is no precise way to link to it!

No I don't know what software versions that 18+ site uses.

Change History (5)

#1 @DJPaul
7 years ago

  • Component changed from Core to Activity
  • Keywords reporter-feedback 2nd-opinion added
  • Type changed from defect (bug) to enhancement

Each individual activity item has its own permalink. Each activity comment redirects to its parent activity item, because a single reply in a threaded discussion doesn't make sense. This is working as intended.

#2 @jidanni
7 years ago

Let's say Margaret Thatcher and the Duke of Earl are having a lengthy conversation all within such comments.

I can't believe there is no way provided to exactly let users zoom in to her comment 321 out of a whole 500 in a thread.

Asking users to dig through all 500 comments to find that would be unreasonable.

I'm not saying to even provide anchors to each individual line in a comment, but just at least to a comment itself.

That is the least that Facebook, bugzilla, and any other blogging thing I can think of does.

And they all do it via a link that one can copy from a timestamp, or comment#.

Can you find other examples of your intended lesser functionality?

#3 @boonebgorges
7 years ago

  • Keywords reporter-feedback 2nd-opinion removed
  • Milestone changed from Awaiting Review to 1.8

your intended lesser functionality?

I don't think DJPaul was suggesting that the current functionality is ideal. He was just recategorizing your bug report (which suggests that something intended to be working is *not* working) as a feature request (which suggests a feature that ought to exist, but doesn't yet).

I think a straightforward path forward is to provide anchors for the comments, so that you could permalink to http://example.com/activity/p/12345/#reply-98761. This isn't as robust as providing truly separate URIs for each comment, but it's far easier to implement, and in any case I agree with DJPaul that it may not make sense to view a single comment out of context. (I think that jidanni is suggesting the anchor route as well.)

If everyone's in agreement, then this should be something easy to implement for BP 1.8.

#4 @jidanni
7 years ago

OK, but whatever you do, make sure it all comes out in RSS too. See also #4740.

#5 @boonebgorges
6 years ago

  • Owner set to boonebgorges
  • Resolution set to fixed
  • Status changed from new to closed

In 7168:

Introduces bp_activity_comment_permalink() and implements in comment template

ID anchors have always been available for the purpose of linking directly to
specific activity comments. But these links have never been available directly
in the interface: the timestamp of specific comments lead to the parent thread,
instead of to the specific comment within that thread. This changeset will make
it easier to find the permalink of specific comments.

Fixes #4741

Note: See TracTickets for help on using tickets.