Skip to:
Content

BuddyPress.org

Opened 7 years ago

Closed 5 years ago

Last modified 3 years ago

#4739 closed enhancement (duplicate)

no fallback to access content for non-javascript browsing

Reported by: jidanni Owned by:
Milestone: Priority: normal
Severity: minor Version:
Component: Templates Keywords:
Cc:

Description

Alas, on e.g.,
http://www.bdsm.com.tw/groups/self-introduction/
at
class="load-more"> <a
href="#more">載入更多$</a></li></ul><form
we see that if it were'nt for this little dependency on javascript,
all the content would be available no matter which browser the user is using.

No I have no idea what Buddypress version they are using.

Change History (9)

#1 @jidanni
7 years ago

Using tcpflow(1) to casually find some URL paramates we might try,
e.g., page2&action=activity_get_older_updates
didn't help.

#2 @jidanni
7 years ago

Also note that load-more button: a short line of text one must precicely click on, despite the enourmous button appearing block which in fact cannot be clicked on that it is placed upon.

#3 @DJPaul
7 years ago

  • Component changed from Core to Theme
  • Keywords needs-patch added
  • Milestone changed from Awaiting Review to Future Release

#4 @jidanni
7 years ago

OK, I found the link to the next page!
http://www.bdsm.com.tw/groups/self-introduction/?acpage=2
Alas it is located far away from the #more button so
most folks would never guess...

#5 @jidanni
7 years ago

Yup, there they are

<noscript><div
class="pagination"><div
class="pag-count">檢視項目 21 - 21 (共有 21 個項目)</div><div
class="pagination-links"><a
class="prev page-numbers" href="/groups/chastityman/?acpage=1">&laquo;</a> <a
class='page-numbers' href='/groups/chastityman/?acpage=1'>1</a> <span
class='page-numbers current'>2</span></div></div> </noscript>

Anyway, it would be nice if clicking on one would zoom one past the gunk at the top, right down to where page 2 etc. really starts.

#6 @jidanni
7 years ago

And what is the noscript way to enjoy these choices?

<li
id="activity-filter-select" class="last"> <label
for="activity-filter-by">顯示:</label> <select
id="activity-filter-by"><option
value="-1">全部</option><option
value="activity_update">狀況更新</option><option
value="joined_group">群組成員</option></select></li>

P.S., and there is no Mediawiki-style &uselang=en parameter so I can give you these examples in English!

Last edited 7 years ago by jidanni (previous) (diff)

#7 @jidanni
7 years ago

"NSFW"

#8 @r-a-y
5 years ago

  • Keywords needs-patch removed
  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Marking this as a duplicate of ticket:5629#comment:6.

#9 @DJPaul
3 years ago

  • Component changed from Appearance - Template Parts to Templates
Note: See TracTickets for help on using tickets.