Skip to:
Content

BuddyPress.org

Opened 9 years ago

Closed 9 years ago

Last modified 6 years ago

#4727 closed enhancement (fixed)

welcome screens need real copy

Reported by: ubernaut Owned by: boonebgorges
Milestone: 1.8 Priority: normal
Severity: normal Version:
Component: Administration Keywords: has-patch
Cc: mrjarbenne, mercijavier@…

Description

thanks for any input!

Attachments (3)

welcome.jpg (164.6 KB) - added by ubernaut 9 years ago.
upgrade.jpg (110.2 KB) - added by ubernaut 9 years ago.
4727.01 (1.7 KB) - added by mercime 9 years ago.
Adding disclaimer and updating link to theme compat

Download all attachments as: .zip

Change History (31)

@ubernaut
9 years ago

@ubernaut
9 years ago

#2 @ubernaut
9 years ago

  • Summary changed from welcome screens needs real copy to welcome screens need real copy

#3 @DJPaul
9 years ago

  • Component changed from Core to Administration
  • Milestone changed from Awaiting Review to 1.7

#4 @mrjarbenne
9 years ago

  • Cc mrjarbenne added

A few thoughts on the mock up attachment:

The reference to the Help Tabs: does this content exist? On a multisite install when you are looking at the Buddypress Settings in the Network Admin, there isn't a help tab, which may confuse people.

I understand the logic of recommending that users start with just the three "core components" but I think that assumes one particular use case, when BuddyPress can be utilized in a number of different ways (I've developed a site using just the groups component, with no activity stream for example). I've tried to re-write this to ensure we aren't suggesting you have to start with these, or that the additional components add additional complications (I think the "if you know what you are doing" line suggests that the additional components are not for beginners), while still trying to adhere to the spirit of the suggestion, which I think is sound for beginners.

Here's my re-write. Hack it apart as necessary.

Welcome to Buddypress

You've just added a host of features that are sure to make your WordPress site an amazing social experience.

New to BuddyPress? Check out the support documentation in the BuddyPress Codex. First Steps with BuddyPress (does this exist, or does it need to be written: I couldn't find it) is a great place to get started.
BuddyPress is built to bring people together, with a host of different components that will help your users connect, network, and make your WordPress site more social.

As you begin building your community, we've activated the following default components to help get you started:

Extended Profiles / Activity Streams / Site Tracking (from ubernaut attachment with explanations)

These components are the heart of BuddyPress, and represent a great starting point as you build your community; but they really just scratch the surface. You can also make Friend Connections, send Private Messages, Create separate Public or Private Groups to organize collaboration, and discuss content in bbPress powered Discussion Forums.

BuddyPress can be fully customized to meet your needs. Check out this page (link to admin) to view and manage all of the components. Start small, then add additional functionality as your community grows, and its needs evolve.

Join the BuddyPress.org community to contribute, find support, and explore plugins and themes that further extend BuddyPress.

Let's get started!

#5 @ubernaut
9 years ago

i like what you have here for whatever that's worth. i was personally just trying to introduce as little interpretation as possible in my mockups so when i could i just copy pasted most of it from the other welcome screens (meaning some of those links may very well not exist but they had counterparts on the other screens so i left them in there). the only thing i would say is that we should maybe try reduce the verbiage a bit but other then that i like what you've done here, personally.

#6 @boonebgorges
9 years ago

(In [6728]) Add a is_new_install $_GET parameter when redirecting to About on fresh install

When building the About/What's New Dashboard panel, it's helpful to know
whether this is a new BuddyPress install, or an upgrade from a previous
version.

See #4727

#7 @boonebgorges
9 years ago

(In [6729]) First pass at copy for About/What's New panel for 1.7.

See #4727

#8 @boonebgorges
9 years ago

Hi ubernaut and mrjarbenne -

First, I meant to give you guys props on the previous commit. Sorry - I'll try to remember for the next pass.

Second, I've just committed a draft for this page. I took inspiration from what both of your guys suggested, but tried to make it a bit less wordy. I also added text for the What's New sections.

In order to make the Getting Started stuff appear only for new installs (especially the default component stuff, which only makes sense in the context of new installations), I had to add another transient. See r6728.

I'm happy to hear suggestions for improvement, etc. I do think that what I've just done is good enough for 1.7-beta1.

#9 @ubernaut
9 years ago

so is this in the current trunk? i looked at the code and the copy looks good just curious to see it in action.

#10 @boonebgorges
9 years ago

so is this in the current trunk?

Yup. svn up, and then visit wp-admin/?page=bp-about

#11 @djpaul
9 years ago

(In [6737]) Update new credits screen with current 1.7 props list and add a few missing textdomains to i18n functions. See #4727

#12 @ubernaut
9 years ago

looks pretty good i wonder if theres a way to trick it into thinking it's a new install so i can see the difference. Also just my two cents but i'd say that site tracking and activity sorta go hand in hand so maybe would be good to have a check for multisite also? one more note the bottom section has two columns but is in 3 column format. let me know if theres anything i can do to help out with the html css stuff and polishing the presentation.

#13 @boonebgorges
9 years ago

i wonder if theres a way to trick it into thinking it's a new install so i can see the difference.

Yup - add &is_new_install=1 to the url.

site tracking and activity sorta go hand in hand so maybe would be good to have a check for multisite also

Are we activating site tracking by default when multisite is enabled? Or is that what you're suggesting?

#14 @ubernaut
9 years ago

Yup - add &is_new_install=1 to the url.

looks good i would say that making graphical representations of the default components would tend to give someone more pause before clicking through.

Are we activating site tracking by default when multisite is enabled? Or is that what you're suggesting?

when i made the mockups i was just looking for a third component to even out the existing 3 column layout from the wp welcome screen but the more i thought about it the more thought that they are sort of the same thing at least in terms of multisite activity and would probably be a key component in a multisite setting. so in short, yes my suggestion. i don't think anyone else has suggested that as default :P

#15 @DJPaul
9 years ago

  • Resolution set to fixed
  • Status changed from new to closed

Now John's added the BP badge for the screens, I think we're done here.

#16 @mercime
9 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Update link to BuddyPress Codex page re BP 1.7 Theme Compatibility
Last edited 9 years ago by mercime (previous) (diff)

#17 @mercime
9 years ago

  • Cc mercijavier@… added
  • Keywords has-patch added

@mercime
9 years ago

Adding disclaimer and updating link to theme compat

#18 @boonebgorges
9 years ago

(In [6886]) Updates theme compat codex link on Welcome panel.

See #4727

Props mercime

#19 @boonebgorges
9 years ago

Thanks, mercime.

I'm not sure about the disclaimer. For one thing, it's true that there will be hiccups with some themes, but it's not exactly something we want to highlight on the Welcome screen, which is intended to be a very brief rundown of new features. For another thing, your disclaimer doesn't seem strictly true. BP theme compat doesn't really depend on a theme's general adherence to WP template hierarchy. We just filter the_content, as long as it appears in some file that exists in the page-buddypress/page/single.php template chain. I'm not aware of any themes that are so far outside of the WP template system that they wouldn't be caught by this (if they are, what makes them WP themes? The fact that they live in the themes directory?). I'm leaning toward leaving the disclaimer out, unless you can steer me right :)

#20 @DJPaul
9 years ago

This is a string change and I told polyglots we were frozen with RC1. Is this essential?

#21 @boonebgorges
9 years ago

Dangit. A good reminder that we should probably be sprintfing URLs.

I think this is nonessential and we should revert.

#22 @mercime
9 years ago

I believe either rephrasing "any WordPress theme" or adding a disclaimer to the phrase is necessary and is essential. I am sorry about the string freeze. And yes, the disclaimer in the patch was not as clear or comprehensive as it should have been. But it would have gone to 2-4 sentences if it was a full disclaimer, not good.

An alternative is to rephrase "any WordPress theme" to for example, "a majority of WordPress themes" or "a majority of WordPress themes available in the market". This protects the brand as BuddyPress cannot be responsible for nor should it be held responsible for themes which were: coded badly or incorrectly, themes which have not been updated for some time, or themes which have fully customized layers of code, and thereby do not work with BP's Theme Compat.

For your consideration.

#23 @boonebgorges
9 years ago

Thanks, mercime.

Can you point to any specific themes where BuddyPress absolutely *doesn't work*? I know there's some funkiness with some themes, but are there instances you know of where theme compat does nothing at all?

In any case, I totally agree with having information about the extent of theme compatibility somewhere in the documentation, but without evidence that serious problems will actually arise in the wild, I don't think that the welcome screen is the place to do it.

#24 @DJPaul
9 years ago

Reverted in r6888

#25 @mercime
9 years ago

Thank you Boone.

Can you point to any specific themes where BuddyPress absolutely *doesn't work*?

I can point to some themes where BuddyPress theme compat doesn't work absolutely per implied guarantee of the tagline "BuddyPress works with any WordPress theme." So if a site admin wants to use Woo's Canvas theme with BP, and there's AJAX conflict with Canvas, [INSERT] site admin can create ticket in trac for resolution to make BP work with Canvas theme, yes?

[INSERT] site admin goes first to support forums, but can't find resolution,

Last edited 9 years ago by mercime (previous) (diff)

#26 @boonebgorges
9 years ago

  • Milestone changed from 1.7 to 1.8

I can point to some themes where BuddyPress theme compat doesn't work absolutely per implied guarantee

I appreciate your assiduous reading of the tagline, but if we were going to be exact, we would put disclaimers on every single sentence of the Welcome screen.

As a policy going forward, if users find reproducible issues with BP's theme compat and specific themes, I'd be happy for them to open discussions either here on at bp.org support. In some cases, there may well be things that BP can/should do to work better with these themes. In other cases, it might be more appropriate for us to make suggestions of the theme author on fixing the compatibility issues.

At the moment, though, I'm going to make the judgment call that there are no known incompatibilities that are so egregious as to make the Welcome text misleading or dishonest (and certainly no more inaccurate than some of the other very general statements on that screen). The fact that we've promised our translators that we're in string freeze makes the case for passing on the disclaimer even stronger.

I'm going to move this ticket to the next milestone, so that we don't forget to take care of the URL update. For the time being, a good stopgap measure would be to put a brief statement at the top of http://codex.buddypress.org/theme-compatibility/ that points to the more comprehensive list of theme-related pages.

Thanks for prompting this discussion, mercime.

#27 @boonebgorges
9 years ago

  • Owner set to boonebgorges
  • Resolution set to fixed
  • Status changed from reopened to closed

In 6927:

Fixes link to theme compat information on About screen.

Fixes #4727

Props mercime

#28 @DJPaul
6 years ago

  • Type changed from task to enhancement
Note: See TracTickets for help on using tickets.