Skip to:
Content

BuddyPress.org

Opened 11 years ago

Closed 11 years ago

#4723 closed defect (bug) (worksforme)

Activity replies are not checked with akismet

Reported by: ubernaut's profile ubernaut Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Activity Keywords:
Cc:

Description

noticed this spam today which was not correlated with any wp-admin activity or bbpress replies

Attachments (1)

Screen Shot 2012-12-18 at 9.48.02 AM.png (402.6 KB) - added by ubernaut 11 years ago.

Download all attachments as: .zip

Change History (10)

#1 @johnjamesjacoby
11 years ago

Do you have evidence to support that it's not being checked? Are you sure it wasn't just an Akismet miss?

#2 @ubernaut
11 years ago

well there was no activity entry and it wasn't listed in the replies if it happens again I'm more then happy to admin you so you can see it for yourself if you like. but to answer your question at this time the evidence (spam) has been deleted there actually was no way to spam it why i submitted the ticket.

Version 1, edited 11 years ago by ubernaut (previous) (next) (diff)

#3 @DJPaul
11 years ago

  • Keywords reporter-feedback added

I'm not sure what you mean by "no activity entry" -- can you screenshot or explain where you're looking?

#4 @ubernaut
11 years ago

  • Keywords reporter-feedback removed
  • Resolution set to invalid
  • Status changed from new to closed

hmm… was just bombed in a similar but somewhat different fashion today and the activity was showing up in the admin panel (which is what i meant by no activity entry, the previous spam i could not find in admin) i guess i must have missed something or whatever. if i see this same thing happen again i will make another ticket and collect a little more info but i suppose at this point this one should be closed.

#5 @DJPaul
11 years ago

  • Milestone Awaiting Review deleted

#6 @ubernaut
11 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

ok I'm pretty sure this is the same thing video:

https://creative.adobe.com/share/52497e3b-123d-4d32-aaf3-ffca69eb386f

Last edited 11 years ago by ubernaut (previous) (diff)

#7 @boonebgorges
11 years ago

  • Milestone set to Awaiting Review

#8 @DJPaul
11 years ago

  • Milestone Awaiting Review deleted

Best way to test any Activity Akismet issues is to:

0) Post a test message to the Activity stream
1) Set your BP profile name to "viagra-test-123"
2) Reply to the first test message
3) Post another test message
4) Reload the activity stream. You should only see the first test message.

You can of course verify that the other two messages exist in the wp-admin screen, and they'll be marked as "flagged as spam by Akismet".
I have just tested this on 1.7/trunk, and everything's working fine. I'm going to close this ticket pending other people recreating it -- I suspect the initial problem was caused by a server, configuration, or temporary Akismet-side problem.

#9 @DJPaul
11 years ago

  • Resolution set to worksforme
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.