Skip to:
Content

BuddyPress.org

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#4666 closed defect (bug) (duplicate)

zip download of trunk broken.

Reported by: modemlooper Owned by:
Milestone: BuddyPress.org Sites Priority: normal
Severity: normal Version:
Component: BuddyPress.org Sites Keywords:
Cc:

Description

SubversionException: ("Can't open file '/home/svn/repos/buddypress/db/revprops/5926': Too many open files", 24)

How to Reproduce

While doing a GET operation on /changeset/6528/tags/1.6.1, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'format': u'zip',
 'new': u'6528',
 'new_path': u'/tags/1.6.1',
 'old_path': u'/'}

User agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_2) AppleWebKit/536.26.17 (KHTML, like Gecko) Version/6.0.2 Safari/536.26.17

System Information

System information not available

Enabled Plugins

Plugin information not available

Python Traceback

Traceback (most recent call last):
  File "build/bdist.linux-x86_64/egg/trac/web/main.py", line 522, in _dispatch_request
    dispatcher.dispatch(req)
  File "build/bdist.linux-x86_64/egg/trac/web/main.py", line 243, in dispatch
    resp = chosen_handler.process_request(req)
  File "build/bdist.linux-x86_64/egg/trac/versioncontrol/web_ui/changeset.py", line 349, in process_request
    self._render_zip(req, filename, repos, data)
  File "build/bdist.linux-x86_64/egg/trac/versioncontrol/web_ui/changeset.py", line 777, in _render_zip
    zipinfo.date_time = new_node.last_modified.utctimetuple()[:6]
  File "build/bdist.linux-x86_64/egg/trac/versioncontrol/api.py", line 1059, in <lambda>
    last_modified = property(lambda self: self.get_last_modified())
  File "build/bdist.linux-x86_64/egg/trac/versioncontrol/svn_fs.py", line 803, in get_last_modified
    core.SVN_PROP_REVISION_DATE, self.pool())
  File "/var/lib/python-support/python2.5/libsvn/fs.py", line 629, in svn_fs_revision_prop
    return apply(_fs.svn_fs_revision_prop, args)
SubversionException: ("Can't open file '/home/svn/repos/buddypress/db/revprops/5926': Too many open files", 24)

Change History (2)

#1 @luccame
9 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of #4645

#2 @johnjamesjacoby
9 years ago

  • Milestone changed from Awaiting Review to BuddyPress.org
Note: See TracTickets for help on using tickets.