Skip to:
Content

Opened 18 months ago

Closed 18 months ago

Last modified 16 months ago

#4634 closed defect (bug) (duplicate)

Wordpress 3.5+ and BuddyPress Upload Avatar Fix

Reported by: NolanD626 Owned by:
Milestone: Priority: normal
Severity: normal Version: 1.6.1
Component: Core Keywords: needs-patch needs-testing
Cc: nolandempster@…

Description

In Wordpress 3.5+ the upload avatar core doesn't not work. The following function needs to be changed from:

	// Check image size and shrink if too large
	if ( $size[0] > bp_core_avatar_original_max_width() ) {
		$thumb = wp_create_thumbnail( $bp->avatar_admin->original['file'], bp_core_avatar_original_max_width() );

to this:

	// Check image size and shrink if too large
	if ( $size[0] > bp_core_avatar_original_max_width() ) {
		$thumb = image_resize( $bp->avatar_admin->original['file'], bp_core_avatar_original_max_width(), null );

In WP 3.5+ wp_create_thumbnail is deprecated.

Attachments (1)

bp-core-avatars.php (29.4 KB) - added by NolanD626 18 months ago.
bp-core-avatars.php

Download all attachments as: .zip

Change History (5)

NolanD62618 months ago

bp-core-avatars.php

comment:2 hnla18 months ago

Well it's a duplicate really!

comment:3 DJPaul18 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Thanks for patch. Closing as duplicate of #4608

comment:4 labsecrets16 months ago

1) Patch works great
2) As of version 1.6.2 - patch does not seem to have been committed to core (?maybe I missed something?)
3) BuddyPress.org still shows only 1.6.1 as download version: http://buddypress.org/download/

Probably we'll see this in 1.6.3 and synch BP page and WP repository versions for download?

Note: See TracTickets for help on using tickets.