Skip to:
Content

#4618 closed defect (bug) (fixed)

Activity stream comments don't add to comment stream

Reported by: anointed Owned by:
Milestone: 1.7 Priority: normal
Severity: normal Version:
Component: Activity Keywords:
Cc: r-a-y

Description

Directly related to this post:
http://buddypress.trac.wordpress.org/ticket/4615

but as it was closed due to buddypress.org not using the system, I am opening it here as I have the exact same problem on my own local install.

Basically I have already had people using the activity stream to make comments to the stream items. Those comments have 2 problems.

  1. when you first make a comment on an activity stream item, and click save, you will see 2 copies of the comment itself

screenshot:
https://dl.dropbox.com/u/2045194/bbpress-trac/buddypress-activity-doubled-comments.png

  1. After you refresh the activity stream page, the problem above goes away and you can see your comment. HOWEVER the comment on the activity stream is NOT copied over to the actual item itself.

example:
If a user comments on a post, that comment is not shown as a comment.
If a user comments on a comment of a post, (a reply to a comment) that reply is not shown on the post page.
This same problem goes on for all activity stream items.

So far, I do not have a single activity stream item that does not have comments, so the comments made in the activity stream should theoretically be able to transfer over without problems.

And should I ever have an item in the activity stream, that doesn't natively allow comments, then the comment box in the activity stream should not show up, thus the potential problem would be alleviated anyhow.

Bottom line:
People are commenting on the activity stream, and because it is not copying over, it is fragmenting the conversations.

Change History (5)

comment:1 anointed18 months ago

Well it seems that almost all of my active users on the site are used to facebook and no matter how much I beg them not to, they are all commenting on the activity stream instead of the original posts.

I'd hate to turn off activity as it is a pretty integral part of buddyPress. Whenever this problem gets resolved, can I request a special function to be added to actually go in and populate all the comments with the missing data from people commenting on the activity stream and not the articles?

thanks.

comment:2 r-a-y18 months ago

Point no. 1 and the first half of point no. 2 should be fixed as of r6452.

The second half of point no. 2 is a duplicate of #1419.

Try disabling activity stream commenting for blog posts and comments in the BP admin area until a plugin or a cross-posted solution is worked out.

comment:3 DJPaul18 months ago

  • Cc r-a-y added

r-a-y, if you're sure r6452 fixed this issue, we need it in 1.6 too, right? (I assume anointed is not using trunk/1.7).

comment:4 johnjamesjacoby17 months ago

  • Component changed from Core to Activity
  • Milestone changed from Awaiting Review to 1.7

This is fixed in trunk, and will be fixed as part of BuddyPress 1.7.

comment:5 johnjamesjacoby16 months ago

  • Resolution set to fixed
  • Status changed from new to closed

Fixed.

Note: See TracTickets for help on using tickets.