Skip to:
Content

BuddyPress.org

Opened 12 years ago

Closed 11 years ago

#4612 closed defect (bug) (no action required)

Guest users unable to use Ajax functions properly on the Groups Loop

Reported by: antaresmhd's profile AntaresMHD Owned by:
Milestone: Priority: normal
Severity: normal Version: 1.7
Component: Core Keywords: needs-patch reporter-feedback
Cc:

Description

Guests users can't get past the first page in the groups loop, and the pagination disappears as soon as they click the arrow or the page number below (using ?grpage=2&num=20 as a GET request works for some reason, though).

I solved this bug in a non-elegant way: the problem was the do_action( 'wp_ajax_nopriv_' . $_REQUEST['action'] ); on the /wp-admin/admin-ajax.php file, line 68. I commented the line and changed the call to do_action( 'wp_ajax_' . $_REQUEST['action'] );, and it all worked. Not sure if doing this entails some kind of security hole, but I was desperate and in need for a fix. If there's a way to create or deactivate this hook in an elegant way, I'm down for it.

Change History (3)

#1 @DJPaul
12 years ago

  • Keywords reporter-feedback added

This is working on trunk/1.7. Will someone check on a 1.6 site please?

#2 @ventoh
11 years ago

I have the same bug on 1.6.4

#3 @boonebgorges
11 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

I've verified that it's working fine on 1.6.x. As of BP 1.6, bp-default adds the wp_ajax_ *and* wp_ajax_nopriv_ ajax handlers. It's possible that this is an issue being caused by a custom theme that's doing it incorrectly (or using a deprecated method of handling AJAX requests).

If you can demonstrate that this is a core BP issue - reproducible on the latest BP trunk, using either bp-default or bp theme compat - please reopen with details.

Note: See TracTickets for help on using tickets.