Skip to:
Content

Opened 18 months ago

Closed 17 months ago

Last modified 17 months ago

#4608 closed defect (bug) (fixed)

wp_create_thumbnail() deprecated as of WP 3.5 - avater uploads will fail currently

Reported by: hnla Owned by:
Milestone: 1.6.2 Priority: highest
Severity: critical Version: 1.6.1
Component: Core Keywords: needs-patch dev-feedback
Cc: hnla, mercijavier@…

Description

As of WP 3.5 wp_create_thumbnail() is deprecated:

Call to undefined function wp_create_thumbnail() in E:\www\vhost\wp-bleeding.dev\site\htdocs\wp-content\plugins\buddypress\bp-core\bp-core-avatars.php on line 521

/wp-admin/includes/deprecated.php : line 1013
@deprecated 3.5.0
@deprecated Use image_resize()

fixed if we set a mandatory third parameter for height:

$thumb = image_resize( $bp->avatar_admin->originalfile?, bp_core_avatar_original_max_width(), $requires_third_paramter_height );

Change History (8)

comment:1 mercime18 months ago

  • Cc mercijavier@… added

comment:2 DJPaul18 months ago

  • Keywords needs-patch added
  • Milestone changed from Awaiting Review to 1.7

comment:3 DJPaul18 months ago

  • Severity changed from major to normal

comment:5 DJPaul18 months ago

  • Keywords dev-feedback added
  • Milestone changed from 1.7 to 1.6.2
  • Priority changed from normal to high
  • Severity changed from normal to critical

The error is thrown because wp_create_thumbnail() was in wp-admin/includes/image.php (which we've explicitly been including), but it's been moved to wp-admin/includes/deprecated.php.

I don't think this can be considered a regression in WP 3.5 as we've always explicitly included a file which is only used inside wp-admin by WP. We need to fix this in the 1.6 branch for a day zero release alongside WP 3.5, which gives us about a month to finish and test 1.6.2.

comment:6 DJPaul17 months ago

  • Priority changed from high to highest

comment:7 djpaul17 months ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [6562]) Fix avatar cropping for WordPress 3.5. Fixes #4608 for the 1.6 branch.

comment:8 djpaul17 months ago

(In [6564]) Fix avatar cropping for WordPress 3.5. Fixes #4608 for trunk.

Note: See TracTickets for help on using tickets.